[问题]升级到7.04,系统的字体都变成了方块

为当前最终发行版之前的所有版本提供支持
回复
cweiyu
帖子: 74
注册时间: 2007-01-08 12:10
送出感谢: 0
接收感谢: 0

[问题]升级到7.04,系统的字体都变成了方块

#1

帖子 cweiyu » 2007-04-18 0:35

崩溃中,firefox和终端里都是可以认识的中英文,但是系统的字体都成了方块,没升级之前的edgy用的是苹果黑体,有没有办法解决这个问题?? :?:
技术?不懂……我就是跟着起哄的
所以我爱看pk版
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-04-18 0:40

设置字体。
都不知道你什么桌面。
● 鸣学
shoory
帖子: 123
注册时间: 2006-08-05 12:47
来自: 四川成都
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 shoory » 2007-04-18 0:58

偶从edgy升到feisty,一直用的文泉驿字体,没有任何问题,哈哈。
cweiyu
帖子: 74
注册时间: 2007-01-08 12:10
送出感谢: 0
接收感谢: 0

#4

帖子 cweiyu » 2007-04-18 8:22

eexpress 写了:设置字体。
都不知道你什么桌面。
GNOME
GUI里怎么设置都是方块
shoory 写了:偶从edgy升到feisty,一直用的文泉驿字体,没有任何问题,哈哈。
好吧,我嫉妒你
技术?不懂……我就是跟着起哄的
所以我爱看pk版
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-04-18 9:26

这情况复杂。简单的只能说升级不完整,或者/etc/fonts下的文件设置不对。看下~/.xsession-errors的字体错误提示信息。
● 鸣学
cweiyu
帖子: 74
注册时间: 2007-01-08 12:10
送出感谢: 0
接收感谢: 0

#6

帖子 cweiyu » 2007-04-18 16:12

eexpress 写了:这情况复杂。简单的只能说升级不完整,或者/etc/fonts下的文件设置不对。看下~/.xsession-errors的字体错误提示信息。
考验我对于命令行的记忆啊...这个errors太长了,找了一些比较可疑的地方:

代码: 全选

(gnome-session:4849): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running pango-querymodules.

(gnome-session:4849): Pango-WARNING **: pango_shape called with bad font, expect ugly output

(gnome-session:4849): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output

(gnome-session:4849): Pango-WARNING **: pango_font_get_font_map called with bad font, expect ugly output

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed

(gnome-session:4849): Pango-WARNING **: _pango_cairo_font_install called with bad font, expect ugly output

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed
Gnome-Message: gnome_execute_async_with_env_fds: returning -1

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed

(gnome-session:4849): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed

代码: 全选

(gnome-panel:4948): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running pango-querymodules.

(gnome-panel:4948): Pango-WARNING **: pango_shape called with bad font, expect ugly output

(gnome-panel:4948): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset.

** (gnome-cups-icon:4978): WARNING **: IPP request failed with status 1280

** (gnome-cups-icon:4978): WARNING **: IPP request failed with status 1280
技术?不懂……我就是跟着起哄的
所以我爱看pk版
回复

回到 “老旧版本支持”