7.04安装问题:grub-instll(hd0)失败!

为当前最终发行版之前的所有版本提供支持
回复
mz
帖子: 24
注册时间: 2007-04-19 13:48
送出感谢: 0
接收感谢: 0

7.04安装问题:grub-instll(hd0)失败!

#1

帖子 mz » 2007-04-19 23:09

试了三回,郁闷啊!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-04-20 0:11

desktop??? 可以live进去。再执行这个。
● 鸣学
mz
帖子: 24
注册时间: 2007-04-19 13:48
送出感谢: 0
接收感谢: 0

#3

帖子 mz » 2007-04-20 6:38

是desktop,我live进去的,安装了三回,格了三次盘,全部宣告失败!硬盘有大量数据,不敢再安装了!
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#4

帖子 drivel » 2007-04-20 7:25

mz 写了:是desktop,我live进去的,安装了三回,格了三次盘,全部宣告失败!硬盘有大量数据,不敢再安装了!
说详细一点嘛,光说失败,谁知道因为什么
mz
帖子: 24
注册时间: 2007-04-19 13:48
送出感谢: 0
接收感谢: 0

#5

帖子 mz » 2007-04-20 9:06

标题已经说了,安装到grub-install的时候失败了,94%的时候!
头像
floweryard
帖子: 17
注册时间: 2007-04-20 9:36
送出感谢: 0
接收感谢: 0

#6

帖子 floweryard » 2007-04-20 9:50

镜像问题?
mz
帖子: 24
注册时间: 2007-04-19 13:48
送出感谢: 0
接收感谢: 0

#7

帖子 mz » 2007-04-20 11:06

我从releases.ubuntu.com上下的,刻盘安装,我想光盘应该没有问题!
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 skyx » 2007-04-20 11:57

eexpress 写了:desktop??? 可以live进去。再执行这个。
ee说得很清楚了
下面的内容也许有帮助,一般grub安装失败都可以修复

live cd 进系统

sudo grub
> root (hd0,0)
>setup (hd0,0)
>quit

也可以把grub安装到/boot所在分区。
mz
帖子: 24
注册时间: 2007-04-19 13:48
送出感谢: 0
接收感谢: 0

#9

帖子 mz » 2007-04-20 13:39

不可修复,因为安装失败后读不出安装的分区如果能读的话是可以修复的(修复办法见7.04beta的方法),在grub4dos里认不出来。
不过这个问题后来解决了,我的办法是在vmware里用.iso文件直接安装到实际的分区,安装成功!
回复

回到 “老旧版本支持”