[问题]如何修改分辨率?

为当前最终发行版之前的所有版本提供支持
回复
chth3137413
帖子: 10
注册时间: 2007-04-21 0:26
来自: 广西柳州
送出感谢: 0
接收感谢: 0
联系:

[问题]如何修改分辨率?

#1

帖子 chth3137413 » 2007-04-21 12:32

我是菜鸟。

昨天装了ubuntu7.04,顺利的进入系统,但是没有装驱动。打开3D效果的时候系统要求下NVIDIA图形加速驱动,下好之后可以开启3D效果,但是还是不能修改分辨率为1440*900。搜索了论坛里的方法,但是还是不清楚怎么弄。各位大哥帮帮忙,谢谢!

显卡:集成G6100
显示器:液19寸宽

xorg.conf内容:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
Fontpath "/usr/share/fonts/X11/misc"
Fontpath "/usr/share/fonts/X11/cyrillic"
Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/Type1"
Fontpath "/usr/share/fonts/X11/100dpi"
Fontpath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "通用显示卡"
Driver "nvidia"
Busid "PCI:0:13:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "通用显示器"
Option "DPMS"
Horizsync 28-51
Vertrefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "通用显示卡"
Monitor "通用显示器"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "stylus" "SendCoreEvents"
Inputdevice "cursor" "SendCoreEvents"
Inputdevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
CPU:AMD Athlon64 X2 Dual Core Processor 3600+
主板:ASUSTeK Computer INC. M2A-VM
内存:Kingston DDRII 667 1GB
硬盘:WDC WD2500YS-01SHB1
显示器:SAMSUNG SyncMaster 931BW
显卡:集成ATI Radeon Xpress 1250
光驱:SAMSUNG TS-H653A
头像
cheno
帖子: 640
注册时间: 2007-03-18 16:17
来自: 汕尾
送出感谢: 0
接收感谢: 1 次

#2

帖子 cheno » 2007-04-21 13:56

同样的问题。。希望大侠帮帮忙。。
还有就是,我在终端里输入sudo gedit /ect/x11/xorg.conf
打开的xorg.conf怎么是空白的?
头像
sailboat
帖子: 16
注册时间: 2007-04-19 10:44
来自: Fs,Gd,China
送出感谢: 0
接收感谢: 0

#3

帖子 sailboat » 2007-04-22 1:51

我是菜鸟,即管说说

1楼的同志,听说在 Modes "1024x768" "800x600" "640x480" 这里添加需要的分辨率就可以。
例如改成: Modes "1440x900" "1024x768" "800x600" "640x480"


2楼的同志,地址输入错了。Linux 是区别大小写字母的
x11 应该为 X11
First Step - GOTO Linux
------------My Linux PC---------
AMD Athlon, 1000 MHz (7.5 x 133)
Epox EP-8K7A(+)
512 MB (PC2100 DDR SDRAM)
Unika 9700DDR (AGP 4x: nVIDIA GeForce2 GTS)
Maxtor 6Y120L0 (114 GB)
CTX PR705F Series
头像
wewe
帖子: 357
注册时间: 2006-05-26 23:40
来自: http://ubuntufans.com
送出感谢: 0
接收感谢: 0

#4

帖子 wewe » 2007-04-22 2:15

sailboat 写了:我是菜鸟,即管说说

1楼的同志,听说在 Modes "1024x768" "800x600" "640x480" 这里添加需要的分辨率就可以。
例如改成: Modes "1440x900" "1024x768" "800x600" "640x480"


2楼的同志,地址输入错了。Linux 是区别大小写字母的
x11 应该为 X11
我也是菜鸟,但是我想你的解答是正确的, :D :D :D
chth3137413
帖子: 10
注册时间: 2007-04-21 0:26
来自: 广西柳州
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 chth3137413 » 2007-04-22 13:03

非常感谢!我试试看。
fyx1487
帖子: 21
注册时间: 2007-04-08 17:24
送出感谢: 0
接收感谢: 0

#6

帖子 fyx1487 » 2007-04-22 13:20

是可以直接添加比如“1280*800”的,我就是那么试的,不过注意那个乘号可以从原来的那儿复制,直接好像打不出来。
chth3137413
帖子: 10
注册时间: 2007-04-21 0:26
来自: 广西柳州
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 chth3137413 » 2007-04-22 14:03

sailboat 写了:我是菜鸟,即管说说

1楼的同志,听说在 Modes "1024x768" "800x600" "640x480" 这里添加需要的分辨率就可以。
例如改成: Modes "1440x900" "1024x768" "800x600" "640x480"


2楼的同志,地址输入错了。Linux 是区别大小写字母的
x11 应该为 X11
解决了!谢谢。 :lol: :lol: :lol:
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#8

帖子 xhy » 2007-04-22 14:58

94 Modes "1024x768"
<x> 120, Hex 78, Octal 170

其实就是个x xyz 里的x
不是什么乘号
目前负债150多万
回复

回到 “老旧版本支持”