请问在kunbuntu中如如何可以一次安装一个完整得包,包括依赖包

为当前最终发行版之前的所有版本提供支持
回复
piky
帖子: 12
注册时间: 2005-10-21 0:02
送出感谢: 0
接收感谢: 0
联系:

请问在kunbuntu中如如何可以一次安装一个完整得包,包括依赖包

#1

帖子 piky » 2005-10-27 15:13

经常遇到找不到依赖包得情况,请问怎么解决

在ubuntu中到有新里得包管理器,但在kubuntu下没阿
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#2

帖子 freeflying » 2005-10-27 15:27

adept
piky
帖子: 12
注册时间: 2005-10-21 0:02
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 piky » 2005-10-27 17:24

但adept不会搜索依赖关系阿
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 catinsnow » 2005-10-27 19:39

dselect
aptitude
都可以吧.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2005-10-27 21:53

全部自动的可能要用到脚本了。主要是有些依赖,系统可能已经安装了。
其实dpkg -s可以一次就找出全部的依赖,包括冲突。

代码: 全选

$ dpkg -s gcc-3.4 
Package: gcc-3.4
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 4404
Maintainer: Debian GCC maintainers
Architecture: i386
Version: 3.4.3-9ubuntu4
Provides: c-compiler
[color=red]Depends[/color]: gcc-3.4-base (>= 3.4.3-9ubuntu4), libgcc1 (>= 1:3.4.3-9ubuntu4), libc6 (>= 2.3.2.ds1-4), cpp-3.4 (>= 3.4.3-9ubuntu4), cpp-3.4 (<< 3.4.5), binutils (>= 2.15-5)
Recommends: libc6-dev (>= 2.3.2.ds1-16)
Suggests: gcc-3.4-doc (>= 3.4.3-9ubuntu4), amd64-libs-dev
[color=red]Conflicts[/color]: gcc-3.2 (<= 1:3.2.3-0pre8)
Description: The GNU C compiler
This is the GNU C compiler, a fairly portable optimizing compiler for C.
.
ABIs changed between gcc-3.3 and gcc-3.4 on some architectures (hppa, m68k, mips, mipsel, sparc). Please read /usr/share/doc/gcc-3.4/README.Debian for more details.
● 鸣学
回复

回到 “老旧版本支持”