Feisty升级记录

为当前最终发行版之前的所有版本提供支持
回复
头像
jackphil
帖子: 59
注册时间: 2006-09-04 23:49
送出感谢: 0
接收感谢: 0
联系:

Feisty升级记录

#1

帖子 jackphil » 2007-04-23 13:15

欢迎去我的博客看看

最新的kubuntu 7.04(开发代号Feisty)已经正式(4月19日)释出,你又可以免费订购光盘了。我自己订购的10套Ubuntu 5.10(开发代号Breezy)一份都没送出去,自己留一份,其余都进垃圾箱了。不好意思再申请了。

看了一下官方的升级指南,不支持跨版本的升级。也就是说我也不能等到下一个版本出来直接升级到7.10,还是与时俱进吧。去官方论坛和中文论坛侦察了一天,发现都是些grub、声卡之类的问题,没有其他严重的bug,反正我是升级,应该没grub多少事,声卡在Edgy下本来就没有声音,如果还是没有声音也没有什么损失。于是决定升级:



我还是选择手动命令行升级,好象官方并不怎么推荐。首先修改源:
sudo sed -e 's/\sedgy/ feisty/g' -i /etc/apt/sources.list进入到recovery模式,开始升级:
sudo aptitude update

sudo aptitude dist-upgrade
下载用了不到2个小时,你也可以使用-d参数在普通模式下先下载,再到recovery模式下安装,这样你可以在这段时间内上上网,听听歌。
安装开始,首先碰到的是关于RAID配置的询问,我这里用不着,关掉了事。
接下来就碰到严重的问题,装不下去了。错误显示有软件包依赖关系无法解决,第1个是apache2-common,后面还跟了一串软件包(python-dev等等)。于是aptitude、apt-get -f、remove、purge的试了很久,还跑到正常模式下查看出错信息,因为我不知道怎样在Console下滚屏,结果都是无法安装下去。最后用dpkg -r删除apache2-common,问题解决。
安装完后不要马上重启,重复运行aptitude dist-upgrade直到没有更新。
重启后进入正常模式,进入桌面一切正常。第一个惊喜是桌面启动差不多结束时的那一段音乐──我的声卡自动识别了。但是显卡驱动不对。查看xorg-driver-fglrx和linux-restricted-modules-2.6.20-15-generic也都已经安装。又去查看配置文件/etc/X11/xorg.conf和日志文件/var/log/Xorg.0.log,仍旧看不出所以然。终于想到Edgy时自己编译显卡驱动,修改了/etc/default/linux-restricted-modules-common,取消了Edgy自带fglrx模块的加载。有够晕的。
安装apache2-common,一切正常。
输入法被自动换成了scim,兼容性问题依旧多多,Firefox中不能激活。改回fcitx,但是一旦输入就会崩溃。去irc上询问,karron建议删掉.fcitx试试,好了,fcitx也正常了。
进入Xgl+Beryl,系统响应变慢,Beryl效果也没出来,虽然窗口管理器已换成Beryl。按照beryl wiki上的指南,降级beryl-core后一切正常:
sudo aptitude install beryl-core=0.2.0~0beryl1

为了不被自动升级,可以将beryl-core设置为保持:
sudo aptitude hold beryl-core
Feisty源中的Beryl是0.2.1版本,与Xgl兼容有问题。Beryl源里的就是降级后的版本0.2.0
最近要在Windows下写几个小软件,VirtualBox也是个关心的问题,去这里下载了feisty对应deb文件后安装,需要自己编译内核模块,预编译的都是针对beta版Feisty内核的,一切正常。
目前唯一明显的问题是关机不能自动关闭电源,老办法,用重启代替,再手动关电源。

总的说来,升级十分顺利,主要是被几个愚蠢的疏忽/错误耽搁了一些时间。初步感觉系统速度有明显提升,这次升级还是很值得的。

Dell的老板也在使用这个系统(这里是中文的新闻),你为什么不也来试一下呢?
回复

回到 “老旧版本支持”