[分享]ubutnu 7.04+nvidia Geforce2 mx 400开启桌面效果成功

为当前最终发行版之前的所有版本提供支持
回复
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

[分享]ubutnu 7.04+nvidia Geforce2 mx 400开启桌面效果成功

#1

帖子 youngcmu » 2007-04-24 12:47

从6.06开始就想弄个3D的桌面效果看看。无奈显卡的驱动总是装不上。7.04安装桌面屏幕有左偏的问题。之前也想过办法解决了。但是总是有点问题。
下载的官方驱动安装总是提示错误。什么no matching precompling kernel interface 之类。今天开始先装了nvidia-glx-legacy 和 nvidia-glx-legacy-dev 和nvidia-glx-kernel-source,这些都是下载的deb包,安装时候提示我软件仓库有更新的版本2.6.15.20,于是安装。开始桌面效果后提示我要安装nvidia-glx的驱动,查看细节发现是9631的驱动,版本是2.6.15.20的版本,好像以前没有看到过,所以又装,自动删除了nvidia-glx-legacy 和 nvidia-glx-legacy-dev.

重启后尝试开启桌面效果。成功!

至此,和以前多次多种方法相比,好像唯一的不同就是多了个nvidia-glx-kernel-source ,不管怎么样,总算是成功了。
希望给有同样问题的用户一些启发。
附件
Screenshot.png
没有截图工具,用键盘保存的一个图片,对我来说,满足了。呵呵。
coandco
帖子: 121
注册时间: 2006-12-15 22:38
送出感谢: 0
接收感谢: 0

#2

帖子 coandco » 2007-04-24 13:08

那个……我是去官网下载个驱动然后装上就OK了。
bigslacker
帖子: 61
注册时间: 2007-01-11 9:57
送出感谢: 0
接收感谢: 0

#3

帖子 bigslacker » 2007-04-24 13:12

楼上正解
楼主以前下官方驱动应该版本不对,可以用NVIDIA-Linux-x86-1.0-9631-pkg1.run
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

Re: [分享]ubutnu 7.04+nvidia Geforce2 mx 400开启桌面效果成功

#4

帖子 stlxv » 2007-04-24 19:10

youngcmu 写了:从6.06开始就想弄个3D的桌面效果看看。无奈显卡的驱动总是装不上。7.04安装桌面屏幕有左偏的问题。之前也想过办法解决了。但是总是有点问题。
下载的官方驱动安装总是提示错误。什么no matching precompling kernel interface 之类。今天开始先装了nvidia-glx-legacy 和 nvidia-glx-legacy-dev 和nvidia-glx-kernel-source,这些都是下载的deb包,安装时候提示我软件仓库有更新的版本2.6.15.20,于是安装。开始桌面效果后提示我要安装nvidia-glx的驱动,查看细节发现是9631的驱动,版本是2.6.15.20的版本,好像以前没有看到过,所以又装,自动删除了nvidia-glx-legacy 和 nvidia-glx-legacy-dev.

重启后尝试开启桌面效果。成功!

至此,和以前多次多种方法相比,好像唯一的不同就是多了个nvidia-glx-kernel-source ,不管怎么样,总算是成功了。
希望给有同样问题的用户一些启发。
我也是这种显卡,很容易就装上了
PHP是最好的语言!不服来战!
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 jaywee » 2007-04-24 19:29

呵,效果看起来不错!!
Time waits for no man!
menstry
帖子: 26
注册时间: 2006-12-20 19:11
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 menstry » 2007-04-24 19:59

7.04不用安装BERY就可以实现3D效果么?
phomeray
帖子: 524
注册时间: 2006-05-30 20:48
送出感谢: 0
接收感谢: 0

#7

帖子 phomeray » 2007-04-24 20:21

我的ti200死活装不上,据说是被官方驱动“污染”了 :em18 现在还是用官方的,让他污染去吧 :em01
jacky-q
帖子: 8
注册时间: 2006-10-01 3:31
送出感谢: 0
接收感谢: 0

#8

帖子 jacky-q » 2007-04-25 1:40

faint,I get 3D effect without video card.....
kangtian
帖子: 336
注册时间: 2007-04-22 13:14
送出感谢: 0
接收感谢: 2 次

#9

帖子 kangtian » 2007-04-25 1:43

我也实验了下,用的就是ISO自带的驱动,可是系统容易假死。
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#10

帖子 youngcmu » 2007-04-25 12:49

这个系统的变数太多了,好像在每个人出现的问题不一样哦。
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#11

帖子 youngcmu » 2007-04-25 12:55

bigslacker 写了:楼上正解
楼主以前下官方驱动应该版本不对,可以用NVIDIA-Linux-x86-1.0-9631-pkg1.run
能够搜索到的方法我都尝试过了。光系统因为装显卡驱动就重装了好几回。驱动什么的就更不用说了。装不上就是装不上!
wolffeng
帖子: 35
注册时间: 2005-10-12 18:16
送出感谢: 0
接收感谢: 0

#12

帖子 wolffeng » 2007-04-25 15:51

6200安装的官网的9755,ubuntu提示使用不兼容设备,3d效果开后,窗口的标题栏显示不正常。
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#13

帖子 内存不足 » 2007-04-25 16:05

都是因为没人详细解释 xorg.conf 里添加的内容的详细解释。
我5200的卡,装了9631就近不去x 装了9755还是近不去。
想起来610的时候 xorg.conf里要添加几行内容,试着给加进去,它就能启动了
Section "Device"里添加:

Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
xinjiemail11
帖子: 94
注册时间: 2006-10-15 18:53
送出感谢: 0
接收感谢: 0

#14

帖子 xinjiemail11 » 2007-04-25 17:28

楼上得签名不厚道~~~

这个叫闷骚 :P
头像
cheno
帖子: 640
注册时间: 2007-03-18 16:17
来自: 汕尾
送出感谢: 0
接收感谢: 1 次

#15

帖子 cheno » 2007-04-25 18:17

我同学的MX440装了系统自动下载的那个驱动后,重启进入桌面后,分辨率变成640*480(好像是这个吧..忘了..呵呵)
怎么改回1024*768呢?
回复

回到 “老旧版本支持”