[问题]为什么说我没有C编译器?

为当前最终发行版之前的所有版本提供支持
回复
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

[问题]为什么说我没有C编译器?

#1

帖子 永恒不永恒 » 2007-04-25 12:23

我装的是ubuntu的6.06,gnome桌面的.
想bt下载的时候,发现默认自带的那个bt下载总遇到中文乱码,导致无法保存种子,自然也无法下载了。
在论坛上搜索一轮,找不到有关的解决方法,就想下载其他的bt客户端看看情况。
在qbittorrent主页上,只看到有未编译的源码包,下载回来。
首先要安装lib,按照readme里面的,
第一步执行 configure,
但是就这个就出问题了,在执行的时候遇到的是这样的情况:

代码: 全选

xzw@VIA-PC1500:~/Download/libtorrent-0.11$sudo ./configure
Password:
checking for a BSD-compatible install .../usr/bin/install -c
checking whether build environment is sane ... yes
checking for gawk ... no
checking for mawk ... mawk
checking for gcc ... no
checking for cc ... no
checking for cl ... no
configure:error: no acceptable C compiler found in $PATH
See 'config.log' for more details.
xzw@VIA-PC1500:~/Download/libtorrent-0.11$
开始以为我自己没有安装编译器,于是打开新立得管理器看看,发现g++4.0/gcc4.0都安装了。那么现在是什么问题导致无法安装呢?[/code]
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-04-25 12:29

执行./configure 前面不要加sudo的,另外你要安装build-essential这个包。
关注我的blog: ε==3
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

#3

帖子 永恒不永恒 » 2007-04-25 12:39

感谢楼上的提示。
不加sudo不行,会提示Permission denied的.
不过在安装了build-essential包后,刚才那个问题解决了,但是在进行到后面的时候,又停下来了
提示:
configure:error:unable to find Boost.DateTime library, currently this is required.
请问应该如何解决呢?
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#4

帖子 Element » 2007-04-25 12:54

缺啥装啥
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2007-04-25 13:04

sudo apt-get install libboost-dev
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “老旧版本支持”