[问题]配置qBittorrent的时候提示找不到qtcore

为当前最终发行版之前的所有版本提供支持
回复
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

[问题]配置qBittorrent的时候提示找不到qtcore

#1

帖子 永恒不永恒 » 2007-04-25 20:29

我用ubuntu 6.06,gnome桌面。
在安装完qBittorrent的lib之后,
开始对qBittorrent 0.9.1进行第一步的配置工作。
但是在执行 sudo ./configure之后,出现了以下的错误提示。

代码: 全选

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.1$ sudo ./configure
Configuring qbittorrent ...
Verifying Qt 4 build environment ... fail

Reason: There was an error compiling 'conf'.  See conf.log for details.

Be sure you have a proper Qt 4.0 build environment set up.  This means not
just Qt, but also a C++ compiler, a make tool, and any other packages
necessary for compiling C++ programs.

If you are certain everything is installed, then it could be that Qt 4 is not
being recognized or that a different version of Qt is being detected by
mistake (for example, this could happen if $QTDIR is pointing to a Qt 3
installation).  At least one of the following conditions must be satisfied:

 1) --qtdir is set to the location of Qt
 2) $QTDIR is set to the location of Qt
 3) QtCore is in the pkg-config database
 4) qmake is in the $PATH

This script will use the first one it finds to be true, checked in the above
order.  #3 and #4 are the recommended options.  #1 and #2 are mainly for
overriding the system configuration.

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.1$
我以为是没有安装qt4,进新立得把qt4的几个包(qt4-designer/qt4-dev-tools/qt4-qtconfig,都是4.12的)都安装上了,但是依然出现这样的情况。
我查看了conf.log文件,里面的记录是这样的:

代码: 全选

/usr/bin/moc-qt4 -DHAVE_MODULES -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. -I. conf4.cpp -o conf4.moc
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DHAVE_MODULES -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. -I. -o conf4.o conf4.cpp
g++  -o conf conf4.o    -L/usr/lib -lQtCore_debug -lpthread
/usr/bin/ld:找不到 -lQtCore_debug
collect2: ld 返回 1
make: *** [conf] 错误 1
请问我应该怎样解决这个问题呢?
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

#2

帖子 永恒不永恒 » 2007-04-25 21:08

顶一下,好像没有人懂..
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 anticlockwise » 2007-04-25 21:09

sudo apt-get install libqt4-dev libqt4-core
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

#4

帖子 永恒不永恒 » 2007-04-25 21:58

感谢楼上。我把qt有关的全部软件包都装了一次,然后再重启一次电脑。
终于过了,然后发现:要求qt>=4.2版本,郁闷啊 。。
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 anticlockwise » 2007-04-25 22:15

那你就得用Ubuntu 6.10或者7.04
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

#6

帖子 永恒不永恒 » 2007-04-25 23:56

就是不小心安装了6.06,然后就不想了..除非能在线升级。好像找不到...
所以现在只好用着6.06了
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
回复

回到 “老旧版本支持”