[问题]请教:校园网内,VMware Server1.0.2下的ubuntu6.10如何上网?

为当前最终发行版之前的所有版本提供支持
回复
bingliang
帖子: 4
注册时间: 2007-04-14 19:41
送出感谢: 0
接收感谢: 0

[问题]请教:校园网内,VMware Server1.0.2下的ubuntu6.10如何上网?

#1

帖子 bingliang » 2007-04-26 14:10

急救!!

请教各位:
近来在学习Linux,先在VM虚拟机上练习着。
系统环境是:WinXP SP2(Host) + VMware Server 1.0.2 + Ubuntu 6.10(Guest)
校园网是静态IP(3A认证绑定)。

一、连到路由器(pplink,用的是网通),XP很正常,Ubuntu正常。用的都是VM的默认设置。

二、连上校园网,XP很正常,Ubuntu连不上。网上看了很多方法都没试成功,比如修改IP和虚拟机的连接方式等。
1、连入校园网后的物理主机(host)设置(需3A认证):
IP:10.60.3.71,
mask:255.0.0.0,
DNS:202.114.200.254
XP的来宾账户和防火墙都已关。
2、设置guest时的相关操作步骤:
(11)、本地连接——属性——高级——选择允许共享Internet,选择了vmnet1;
(12)、vmnet1 的ip: 192.168.0.1,
mask:255.255.255.0
(13)、vmware中,vm——settings——Ethernet——选择了custom:vmnet1
(14)、Ubuntu中,eth0 ip:192.168.0.2
mask:255.255.255.0
gateway:192.168.0.1
DNS:202.114.200.254
(15)、保存设置,并重起服务,ping不到主机。不能上网!
(16)、本地连接——属性——高级——允许共享Internet下选择vmnet8;
(17)、vmnet8 的ip:192.168.0.1,
mask:255.255.255.0
(18)、vmware中,vm——settings——Ethernet——选择了custom:vmnet8
(19)、Ubuntu中,eth0 ip:192.168.0.2
mask:255.255.255.0
gateway:192.168.0.1
DNS:202.114.200.254
(110)、保存设置,并重起服务,ping不到主机。不能上网!
-------------------------------
后来又这样尝试:
(21)、本地连接——属性——高级——取消允许共享Internet;
(22)、vmnet1 的ip: 192.168.252.1
mask:255.255.255.0
(23)、vmware中,vm——settings——Ethernet——选择了custom:vmnet1
(24)、Ubuntu中,eth0 ip:192.168.252.2
mask:255.255.255.0
gateway:192.168.252.1
DNS:202.114.200.254
(25)、保存设置,并重起服务,ping不到主机。不能上网!
(26)、vmnet8 的ip: 192.168.126.1
mask:255.255.255.0
(28)、vmware中,vm——settings——Ethernet——选择了custom:vmnet8
(29)、Ubuntu中,eth0 ip:192.168.126.2
mask:255.255.255.0
gateway:192.168.126.1
DNS:202.114.200.254
(210)、保存设置,并重起服务,ping不到主机。不能上网!

经过上述步骤,仍不能上网,不知道错在哪里?请大家多多指点。
没办法,折腾好多天了,反正是失败了,请有经验的“前辈”为我解难!谢谢!
bingliang
帖子: 4
注册时间: 2007-04-14 19:41
送出感谢: 0
接收感谢: 0

#2

帖子 bingliang » 2007-04-27 12:20

看来好像没人回应啊?
各位学长们没有遇到过类似的问题么?

以下是我昨天新的尝试,试验成功!
(1)、winxp中,本地连接——属性——高级——选择“允许共享Internet”,选择了vmnet8;
(2)、查看vmnet8, ip: 192.168.0.1 ,mask:255.255.255.0
(3)、vmware中,vm——settings——Ethernet——选择了custom:vmnet8 (NAT)
(4)、Ubuntu中,eth0 ip:192.168.0.3,mask:255.255.255.0 ,gateway:192.168.0.1,DNS:(本地校园网DNS)
(5)、保存设置,并重起服务,在Ubuntu 中“ping”主机正常(注意防火墙设置,如果禁止则ping不到),在主机中“ping” Ubuntu也正常,但Ubuntu还是不能上网!
(6)、网上下了个CCProxy代理服务器装到了xp上,搜索到了“192.168.0.3”并设置代理;在Ubuntu 中“系统管理”——“代理设置”,填好主机的IP地址,Ubuntu终于能上网啦!

总觉得此方法不是最好的方法,主机上校园网要3A认证,既然都连上了却还要设代理,Ubuntu不能直接共享么?
所以期待学长们指教更好的办法。
回复

回到 “老旧版本支持”