安装7.04后显示器分辨率不能更改!

为当前最终发行版之前的所有版本提供支持
回复
头像
新手
帖子: 455
注册时间: 2007-01-22 23:23
来自: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1 次
接收感谢: 0

安装7.04后显示器分辨率不能更改!

#1

帖子 新手 » 2007-04-26 20:40

我的显示器默认的分辨率本来是1280*1024的,昨天装完ubuntu7.04后进入桌面发现分辨率为1024*768,而且不能更改。我的显卡是NVIDIA Geforce 7300GT的,是不是显卡的原因?如果是,我该换什么样的显卡?
头像
hao123liu
帖子: 887
注册时间: 2007-02-11 13:27
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 hao123liu » 2007-04-26 20:54

应该是没装驱动问题
可以去搜一下论坛应该有方法的
头像
aqua203
帖子: 283
注册时间: 2007-03-01 21:04
来自: 福建
送出感谢: 0
接收感谢: 0

#3

帖子 aqua203 » 2007-04-26 22:34

请贴出你的xorg.conf
sudo gedit /etc/X11/xorg.conf
yalelynn
帖子: 15
注册时间: 2007-03-18 17:32
送出感谢: 0
接收感谢: 0

#4

帖子 yalelynn » 2007-04-26 23:01

是不是livecd下不能更改分辨率呢?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#5

帖子 jarlyyn » 2007-04-27 0:13

试下

系统->系统管理->受限驱动管理器
lzwxiaotian
帖子: 31
注册时间: 2007-04-17 20:28
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 lzwxiaotian » 2007-04-27 11:19

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation C51G [GeForce 6100]"
Driver "nv"
BusID "PCI:0:5:0"
EndSection

Section "Monitor"
Identifier "F710B"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation C51G [GeForce 6100]"
Monitor "F710B"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
头像
新手
帖子: 455
注册时间: 2007-01-22 23:23
来自: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1 次
接收感谢: 0

#7

帖子 新手 » 2007-05-07 12:53

多谢楼上各位!

现在用sudo nvidia-settings命令可以将分辨率改为1280x1024但重启后又自动改为1024x768,不知道是什么原因。
头像
stlxv
论坛版主
帖子: 8274
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2007-05-07 13:30

新手 写了:多谢楼上各位!

现在用sudo nvidia-settings命令可以将分辨率改为1280x1024但重启后又自动改为1024x768,不知道是什么原因。
你的驱动其实没装,你用的是默认的驱动

P.S. 到底是怎样的不能改动????改分布率用系统->首选项->屏幕分辨率
PHP是最好的语言!不服来战!
头像
新手
帖子: 455
注册时间: 2007-01-22 23:23
来自: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1 次
接收感谢: 0

#9

帖子 新手 » 2007-05-10 18:25

stlxv 写了:
新手 写了:多谢楼上各位!

现在用sudo nvidia-settings命令可以将分辨率改为1280x1024但重启后又自动改为1024x768,不知道是什么原因。
你的驱动其实没装,你用的是默认的驱动

P.S. 到底是怎样的不能改动????改分布率用系统->首选项->屏幕分辨率
也许是驱动没装上,因为在系统--系统管理里面有一个“受限驱动管理器,NVIDIA图形加速驱动,已启用。

我用系统--首选项--屏幕分辨率首选项,改完以后重启 系统又恢复到原来的1024*768了。
头像
iblicf
帖子: 3766
注册时间: 2007-01-15 17:15
送出感谢: 0
接收感谢: 0

#10

帖子 iblicf » 2007-05-10 19:09

"nVidia Corporation C51G [GeForce 6100]"
Driver "nv"
明显驱动没装好!
1. 安装 nvidia-glx (synaptic)
2. sudo nvidia-xconfig
3. [Ctrl-Alt-Backspace ] 重启xserver
4. sudo vi /etc/X11/xorg.conf
after ( Driver "nvidia") Option "nologo"

或者你直接把 "nv" 变成 "nvidia" 试验一下
然后 :系统-首选项-屏幕分辨率
头像
新手
帖子: 455
注册时间: 2007-01-22 23:23
来自: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1 次
接收感谢: 0

#11

帖子 新手 » 2007-05-12 9:56

iblicf 写了:
"nVidia Corporation C51G [GeForce 6100]"
Driver "nv"
明显驱动没装好!
1. 安装 nvidia-glx (synaptic)
2. sudo nvidia-xconfig
3. [Ctrl-Alt-Backspace ] 重启xserver
4. sudo vi /etc/X11/xorg.conf
after ( Driver "nvidia") Option "nologo"

或者你直接把 "nv" 变成 "nvidia" 试验一下
然后 :系统-首选项-屏幕分辨率
执行sudo vi /etc/X11/xorg.conf后出现以下字符,不知所云:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Nov 9 17:55:20 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#12

帖子 Element » 2007-05-12 10:11

别用VI了,还是用gedit吧。
gksu gedit /etc/X11/xorg.conf
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
冲浪板
论坛版主
帖子: 7466
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#13

帖子 冲浪板 » 2007-05-12 10:25

这种帖子的题目明显题不对文。
lzwxiaotian
帖子: 31
注册时间: 2007-04-17 20:28
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 lzwxiaotian » 2007-05-12 11:19

kan qianmian de tezhi
头像
新手
帖子: 455
注册时间: 2007-01-22 23:23
来自: 42 39'18.85"N,94 10'00.80"E
送出感谢: 1 次
接收感谢: 0

#15

帖子 新手 » 2007-05-12 11:37

冲浪板 写了:这种帖子的题目明显题不对文。
此帖是以前发的,现在已经能改分辨率了,只是重启后又恢复原状。

懒得再发新帖求教于是便在旧帖中提问。

见谅!
回复

回到 “老旧版本支持”