当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [讨论]分辨率问题
帖子发表于 : 2007-04-26 23:30 
头像

注册: 2007-04-14 20:08
帖子: 104
送出感谢: 6
接收感谢: 0 次
各位高手,我的显卡是GeForce4 MX 4000 AGP 8x,装的是7.04,15寸的球面显示器,我只能在800*600@51HZ的状态下才能正常显示,1024*768@50HZ就很闪,1024*768@53HZ就死机,我要怎样设置才能在1024*768的分辨率下正常使用?



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
Fontpath "/usr/share/X11/fonts/misc"
Fontpath "/usr/share/X11/fonts/cyrillic"
Fontpath "/usr/share/X11/fonts/100dpi/:unscaled"
Fontpath "/usr/share/X11/fonts/75dpi/:unscaled"
Fontpath "/usr/share/X11/fonts/Type1"
Fontpath "/usr/share/X11/fonts/100dpi"
Fontpath "/usr/share/X11/fonts/75dpi"
Fontpath "/usr/share/fonts/X11/misc"
# path to defoma fonts
Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom"# Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom"# Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom"# Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Horizsync 28-51
Vertrefresh 45-120
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "stylus" "SendCoreEvents"
Inputdevice "cursor" "SendCoreEvents"
Inputdevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection


附件:
Screenshot-受限制的驱动.png
Screenshot-受限制的驱动.png [ 13 KiB | 被浏览 718 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-27 12:15 

注册: 2006-08-15 22:21
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
这是刷新率的问题,我的液晶显示器也碰到了这种事情,真受不了,以前用6.10的时候就挺好。好了,废话少说,以下是我的解决办法。
方法一: 找出显示器说明书或是查找显示器制造商的网站,查清显示器 Horizsync 和 Vertrefresh 的正确范围,然后在xorg.cong的section"Monitor"中修改。从你现在的配置文件看,显然这个范围太低了。然后根据你平时常用的刷新率(我猜测一下,如果是球面显示器,应该是85左右,当然我只是胡猜,还得看你在windows下的最大刷新率为准)修改section"screen",强制系统接受新刷新率。比如说,我希望我的显示器在1024*768有75的刷新率,就这样改: Modes "1024x768_75" "800x600" "640x480",注意,很简单,分辨率后加个下划线写上75就可以了,当然由于系统默认使用24位的颜色,所以最关键的是要修改
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
这一块。重新启动后,不出意外的话就可以了。有趣的是,用系统自带的修改分辨率的工具查看,刷新率还是在五十多,但是不要去管他,其实已经是75的刷新率了。我的液晶显示器可以显示当前的刷新率,所以我确定是改对了。如果你的显示器也有这个功能不妨查看一下。需要注意的是,系统自带的那个修改分辨率的工具不能再去用它了,否则可能还会给他该回去。

方法二: 最直接,在终端内输入:sudo nvidia-settings,使用显卡自带的工具,里面可以很直观的修改分辨率和刷新率,改完后让其自动生成一份xorg.conf文件,并覆盖原来的。这个方法的好处是很快很简单,不好的地方是nvidia自己生成的xorg.conf和系统自己生成的那份有点不一致,主要是支持beryl和compiz的那些选项都没有了,如果你要使用3d桌面并不希望在登录前看到nvidia的徽标,还得老老实实把
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
这三个选项添回去。另外好像键盘也会出一点问题,至少我用的德文键盘出了点问题。不知道英文键盘有没有事。当然,系统自带的那个修改分辨率的工具同样不要再用了。

这两个方法我偏向于第一种,稍微麻烦了一点点,但没什么后顾之忧,希望对你有帮助。
(修改xorg.conf文件,难以排除风险的存在,所以多少也要有点心理准备啊 :D


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-28 22:02 
头像

注册: 2007-04-14 20:08
帖子: 104
送出感谢: 6
接收感谢: 0 次
终于成功了,感激不尽呀!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-28 22:17 
头像

注册: 2007-04-14 20:08
帖子: 104
送出感谢: 6
接收感谢: 0 次
重启后又不成了,怎样搞才行呀?一重启就打回原状了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-28 22:19 
头像

注册: 2006-11-11 17:14
帖子: 833
地址: 浙江宁波
送出感谢: 0 次
接收感谢: 0 次
帮你顶了!!!


_________________
时间过得快啊!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-28 22:28 

注册: 2006-09-24 9:46
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
是不是关机时,那个“为下次登录保存会话”没有勾选上……


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-28 23:03 
头像

注册: 2007-04-14 20:08
帖子: 104
送出感谢: 6
接收感谢: 0 次
终于完全弄好了,说一下我的经验吧,

首先在终端输入“gksu nautilus”以取得管理员身份来修改“/etc/X11”中的“xorg.conf”的权限,打开“xorg.conf”,然后更改其中“HorizSync”的参数,我原来的是:”28-51 “,我估计我的显示器可以上到85的,我就改为”28-85“,然后保存退出。再在终端输入“ sudo nvidia-settings”,出现对话框后修改“X Server Display Configuration”的“resolution”选项,选择“1024X768”,将刷新率为85,按“SAVE TO CONFIGURATOIN,然后确认退出。这样就可以得到一个1024*768的稳定的分辨率了,但如果这时重启的话还是会打回原型的,我再入”系统--首选项--屏幕分辨率“这时将1024X768的刷新率高至57(这时应该有这个选项的,后来我再改了XCONFIG之后就只剩下54了),保存退出以后重启也可以有1024X768@85HZ的分辨率了。
这是我的操作过程,请各位前辈批评批评指导,有错误的地方请指出,我还是一只菜菜鸟,我看到论坛里有很多人有问关于分辨率的问题,希望可以给不能设置的兄弟们一点帮助。 :lol:
补充一点,不知道为什么,我设了1027*768@85HZ以后,就不能用桌面效果了,而且在整个设置过程中也不能开启桌面效果,如果开启了就一定死机收场,请高手们指导指导


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-29 2:11 

注册: 2005-03-27 17:11
帖子: 113
地址: Seattle, USA
系统: Linux Mint 14 Nadia
送出感谢: 0 次
接收感谢: 0 次
我是不管怎么改也改不到85HZ,什么都试过了,就是看不到85这个数字。气死了。。


_________________

http://guanyu.info
simplicity is the key to brilliance


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-29 2:26 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
sudo nvidia-settings


_________________
blog:杰林修·呓


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-29 2:28 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
另外
mx440,手选项设50=80hz
53=75hz

在显示器的osd里看到的数据


_________________
blog:杰林修·呓


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-29 8:12 

注册: 2006-08-15 22:21
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
vcan 写道:
终于完全弄好了,说一下我的经验吧,

首先在终端输入“gksu nautilus”以取得管理员身份来修改“/etc/X11”中的“xorg.conf”的权限,打开“xorg.conf”,然后更改其中“HorizSync”的参数,我原来的是:”28-51 “,我估计我的显示器可以上到85的,我就改为”28-85“,然后保存退出。再在终端输入“ sudo nvidia-settings”,出现对话框后修改“X Server Display Configuration”的“resolution”选项,选择“1024X768”,将刷新率为85,按“SAVE TO CONFIGURATOIN,然后确认退出。这样就可以得到一个1024*768的稳定的分辨率了,但如果这时重启的话还是会打回原型的,我再入”系统--首选项--屏幕分辨率“这时将1024X768的刷新率高至57(这时应该有这个选项的,后来我再改了XCONFIG之后就只剩下54了),保存退出以后重启也可以有1024X768@85HZ的分辨率了。
这是我的操作过程,请各位前辈批评批评指导,有错误的地方请指出,我还是一只菜菜鸟,我看到论坛里有很多人有问关于分辨率的问题,希望可以给不能设置的兄弟们一点帮助。 :lol:
补充一点,不知道为什么,我设了1027*768@85HZ以后,就不能用桌面效果了,而且在整个设置过程中也不能开启桌面效果,如果开启了就一定死机收场,请高手们指导指导


"方法二: 最直接,在终端内输入:sudo nvidia-settings,使用显卡自带的工具,里面可以很直观的修改分辨率和刷新率,改完后让其自动生成一份xorg.conf文件,并覆盖原来的。这个方法的好处是很快很简单,不好的地方是nvidia自己生成的xorg.conf和系统自己生成的那份有点不一致,主要是支持beryl和 compiz的那些选项都没有了,如果你要使用3d桌面并不希望在登录前看到nvidia的徽标,还得老老实实把
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
这三个选项添回去。"

既然你动用了sudo nvidia-settings,那就必须把那三个选项再手动添回去。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-04-29 8:31 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
jarlyyn 写道:
另外
mx440,手选项设50=80hz
53=75hz

在显示器的osd里看到的数据


fx5200
50 = 75hz
55 = 60hz
三星LCD 732N


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译