当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能安装build-essential
帖子发表于 : 2007-04-27 13:47 

注册: 2007-04-01 9:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
使用命令sudo apt-ger install build-essential显示

build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
不知道大家有没有遇见过这个问题。怎么解决的。我用的是XP+虚拟机的方式安装的ubuntu


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-27 13:56 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo aptitude install ****


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-27 14:28 

注册: 2007-04-01 9:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
使用了楼上的命令还是不能安装;反馈如下
下列软件包存在未满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.5-1ubuntu12.5.10.1) 但是 2.4-1ubuntu12 已安装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-27 14:31 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
LZ用的 ubuntu的版本?


_________________
blog:杰林修·呓


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-27 14:32 

注册: 2007-04-01 9:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
感觉比较奇怪。这个依赖版本更高应该兼容才对阿。现在这么出现这种问题。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-27 14:44 

注册: 2007-04-01 9:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
用的是ubuntude6.10版本。你有什么好的建议吗??


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-27 16:00 
头像

注册: 2006-05-19 9:54
帖子: 1822
地址: Shanghai
送出感谢: 2
接收感谢: 11
估计源里的软件包不同步了
把2.4的libc用dpkg删了再安装吧


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-27 17:10 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
xinchen97 写道:
使用了楼上的命令还是不能安装;反馈如下
下列软件包存在未满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.5-1ubuntu12.5.10.1) 但是 2.4-1ubuntu12 已安装


它会给一些解决方案的


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-27 18:12 

注册: 2007-03-17 18:57
帖子: 124
地址: 广东广州
送出感谢: 0 次
接收感谢: 0 次
xinchen97 写道:
感觉比较奇怪。这个依赖版本更高应该兼容才对阿。现在这么出现这种问题。


根据我在最近安装qBittorrent的经验来说,
更高版本不一定是往下兼容的。比如我安装qBittorrent的lib的时候,在checking gcc的时候告诉我说没有找到gcc,但是我看了一下我已经安装了gcc 4.0了,很明显,它不认得gcc4.0,只认识gcc。所以我把gcc 也装上,然后这个check就通过了。
通过这个例子,说明有时候在检查版本的时候,不一定更高的版本就适合或者向下兼容。如果你发现你已经安装了高版本却依然报告说没有找到包的时候,就应该考虑是否有安装它所要求的比较低的版本。


_________________
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译