求助 更新错误

为当前最终发行版之前的所有版本提供支持
回复
jxing1234
帖子: 74
注册时间: 2007-04-13 11:53
送出感谢: 0
接收感谢: 0

求助 更新错误

#1

帖子 jxing1234 » 2007-04-28 14:22

今天开机就发现右上角有更新图标,鼠标移上去 就显示
出现一个 错误,请在右键菜单中运行 package manager 或在终端使用apt-get 查看相关错误信息,错误信息为 error:opening the cache (e:problem parsing dependency depends,e:error occurred while processing bmpwma(mewversion1).E: Problem with MergeList /var/lib/apt/lists/ubuntu.cn99.com_ubuntu-cn_dists_edgy_main_binary-i386_Packages
E: the package lists orstatus file could not be parsed or opened

在终端使用apt-get :
oxen@oxen-laptop:~$ apt-get
apt 0.6.45ubuntu14.2 for linux i386 ,编译于 Feb 23 2007 11:09:53
用法: apt-get [选项] 命令
apt-get [选项] install|remove 包甲 [包乙 ...]
apt-get [选项] source 包甲 [包乙 ...]

apt-get 提供了一个用于下载和安装软件包的简易命令行界面。
最常用命令是 update 和 install。

命令:
update - 下载更新软件包列表信息
upgrade - 进行一次升级
install - 安装新的软件包(注:包名是 libc6 而非 libc6.deb)
remove - 卸载软件包
source - 下载源码包文件
build-dep - 为源码包配置所需的构建依赖关系
dist-upgrade - 发布版升级,见 apt-get(8)
dselect-upgrade - 根据 dselect的选择来进行升级
clean - 删除所有已下载的包文件
autoclean - 删除老版本的已下载的包文件
check - 核对以确认系统的依赖关系的完整性
选项:
-h 本帮助文档。
-q 让输出可作为日志 - 不显示进度
-qq 除了错误外,什么都不输出
-d 仅仅下载 - 【不】安装或解开包文件
-s 不作实际操作。只是依次模拟执行命令
-y 对所有询问都作肯定的回答,同时不作任何提示
-f 当没有通过完整性测试时,程序仍试图继续执行
-m 当有包文件无法找到时,程序仍试图继续执行
-u 显示已升级的软件包列表
-b 在下载完源码包后,编译生成相应的软件包
-V 显示详尽的版本号
-c=? 读取指定配置文件
-o=? 设置任意指定的配置选项,例如 -o dir::cache=/tmp
请查阅 apt-get(8)、sources.list(5) 和 apt.conf(5)的参考手册
以获取更多信息和选项。
本 APT 有着超级牛力。


运行新立德 也提示错误。
附件
Screenshot.png
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#2

帖子 avauntage » 2007-04-28 14:50

恩,这是是服务器有点问题。

代码: 全选

$ sudo gedit /etc/apt/sources.list

把里面有ubuntu-cn的行注释掉。
然后再

代码: 全选

sudo apt-get update
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
回复

回到 “老旧版本支持”