求救,今天搞了一个下午没解决的apt-get问题

为当前最终发行版之前的所有版本提供支持
回复
darknight512
帖子: 6
注册时间: 2007-02-01 19:39
送出感谢: 0
接收感谢: 0

求救,今天搞了一个下午没解决的apt-get问题

#1

帖子 darknight512 » 2007-04-28 17:23

我的版本是edgy ubuntu,昨天一切正常,今天开始突然出现用synaptic 升级时,会报以下错误

代码: 全选

E: Problem parsing dependency Depends
E: Error occurred while processing bmp-wma (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ubuntu.cn99.com_ubuntu-cn_dists_edgy_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
而且之后synaptic就会自动关闭

即使在terminal下也是报同样的错误。google了一下午,找到以下几种方法:
1.用 /var/lib/dpkg/status-old 覆盖 /var/lib/dpkg/status 无效

2.用 /var/backups/dpkg.status.0 来覆盖/var/lib/dpkg/status,包括解压出 dpkg.status.1.gz中的dpkg.status.0 来覆盖 无效

3.修改 /etc/apt/apt.conf.d/70debconf,加上APT::Cache-Limit 83886080; 无效

4.使用命令
sudo apt-get clean
sudo apt-get -f install
报的和上面一样的错,现在不能升级软件了,
:cry:

后来尝试用KPackage,虽然报同样的错,但至少不会像synaptic一样自动关闭,然后在其中查找bmp-wma文件,发现是在 dpkg安装中的,dpkg 的版本是1.13.22ubuntu7

我自己琢磨,是不是这个版本有问题啊?ubuntu7?

现在该怎么办啊,哪位大侠可怜可怜我吧,现在什么升级都不能进行了。

P.S.在GNOME下的kpackage怎么不要 super密码就能直接进去呢?好不安全啊。

-------------------------------------------------
我解决了,可参加 viewtopic.php?t=51386
zhshli8324
帖子: 7
注册时间: 2007-03-04 10:15
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhshli8324 » 2007-04-29 17:15

同问,我遇到了同样的问题。
zhshli8324
帖子: 7
注册时间: 2007-03-04 10:15
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zhshli8324 » 2007-04-29 17:27

zhan 写了:由于服务器升级,今天 ubuntu-cn 的源有点问题,因此如果有这样的问题,就把 sources.list 中的 ubuntu-cn 的那一行注释掉,暂时不用就好了.

找到了,按上面做,正常了。
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#4

帖子 windwiny » 2007-04-29 17:39

服务器? -cn 最“原始”的服务器是哪一台?

我同时加了 cn99,rootguide,cnsite 的源,结果三个源的 -cn 都有问题了, 这应该不是 UBT官方维护的吧?
回复

回到 “老旧版本支持”