[问题]apt-get依赖关系问题。

为当前最终发行版之前的所有版本提供支持
回复
chop
帖子: 4
注册时间: 2007-03-09 16:50
送出感谢: 0
接收感谢: 0

[问题]apt-get依赖关系问题。

#1

帖子 chop » 2007-04-28 23:29

现在安装任何东西依赖关系都不能自动解决,使用apt-get -f install没有报错,不知道问题出在哪里,有大大能帮忙解决么,谢谢。

情况如下:

chop@chop-desktop:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 0%
正在分析软件包的依赖关系树... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
chop@chop-desktop:~$
chop@chop-desktop:~$ sudo apt-get install ssh
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
ssh: 依赖: openssh-server 但是它将不会被安装
E: 无法安装的软件包
chop@chop-desktop:~$
darknight512
帖子: 6
注册时间: 2007-02-01 19:39
送出感谢: 0
接收感谢: 0

#2

帖子 darknight512 » 2007-04-28 23:37

我也遇到类似问题,这是我的解决方法,希望对你有帮助

viewtopic.php?t=51386
chop
帖子: 4
注册时间: 2007-03-09 16:50
送出感谢: 0
接收感谢: 0

#3

帖子 chop » 2007-04-29 10:53

呵呵,我们的问题不一样。
楼上的是源的问题,我的应该是配置的问题,不过我不记得有改过配置,前一天下载fcitx的时候还正常的,昨天就出问题了,不知道为什么。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-04-29 10:57

换源。今天cn99的源被别人搞坏了
● 鸣学
chop
帖子: 4
注册时间: 2007-03-09 16:50
送出感谢: 0
接收感谢: 0

#5

帖子 chop » 2007-04-29 11:38

是的,今天软件更新有问题,直接退出界面了
回复

回到 “老旧版本支持”