新立得和aptitude,为何会有区别?

为当前最终发行版之前的所有版本提供支持
回复
头像
goodhebin
帖子: 101
注册时间: 2006-10-14 15:41
来自: 厦门
送出感谢: 0
接收感谢: 0
联系:

新立得和aptitude,为何会有区别?

#1

帖子 goodhebin » 2007-04-29 16:41

我不知道系统中的新立德到底怎么管理软件包的,不是根据网站上的软件索引吗,aptitude也是根据源上的软件索引判断依赖关系,当然deb包里也包含了软件的依赖关系信息,不过至少新立德和aptitude是根据同样的标准判断依赖的吧,但是现在我的系统中新立德判断系统软件和依赖没有问题,但是aptitude却告诉我有一些依赖没有满足,建议我安装需要的依赖包,这是怎么回事呢
附件
aptitude.png
.png
CPU:P4 2.93G
主板:sis661fx
ati 9600移动卡
512M
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-04-29 16:54

aptitude把推荐包也当成依赖包了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

#3

帖子 tommy007 » 2007-04-29 17:37

aptitude把推荐包也要求安装
新立得同apt-get
头像
goodhebin
帖子: 101
注册时间: 2006-10-14 15:41
来自: 厦门
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 goodhebin » 2007-04-29 17:52

那一般推荐包有对软件有什么作用?
我们需不需要装上推荐包,什么情况该装推荐包。
CPU:P4 2.93G
主板:sis661fx
ati 9600移动卡
512M
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#5

帖子 Nile » 2007-04-29 18:00

ubuntu参考手册:
软件包A推荐(recommends)软件包B:软件包维护者认为所有用户都不会喜欢缺少某些功能的A,而这些功能需要B来提供。
软件包A依赖(depends)软件包B:要运行A必须安装B。在有些情况下,A不仅依赖B,还要求B的特定版本。版本依赖通常有最低版本限制,A更依赖于B的最新版而非某个特定版本。
Thinkpad T400
回复

回到 “老旧版本支持”