the composite extension is not availalbe??!!求助!!

为当前最终发行版之前的所有版本提供支持
回复
staryin
帖子: 60
注册时间: 2007-04-19 20:07
送出感谢: 0
接收感谢: 0

the composite extension is not availalbe??!!求助!!

#1

帖子 staryin » 2007-04-29 19:14

我装显卡驱动后,打开DESKTOP EFFECT 它说“the composite extension is not available??
这是怎么回事??
显卡是ati xpress 1150
参考文章是http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide
求助 !!
andrew_t
帖子: 614
注册时间: 2006-12-14 3:00
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 andrew_t » 2007-04-29 22:52

那个网页里面都说了,首先要“ Disable Composite Extension”

要用fglrx驱动,就必须禁用composite extension
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#3

帖子 stlxv » 2007-04-29 23:37

andrew_t 写了:那个网页里面都说了,首先要“ Disable Composite Extension”

要用fglrx驱动,就必须禁用composite extension
PHP是最好的语言!不服来战!
staryin
帖子: 60
注册时间: 2007-04-19 20:07
送出感谢: 0
接收感谢: 0

#4

帖子 staryin » 2007-04-30 8:24

怎么禁用composite extension???
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#5

帖子 forrid » 2007-06-05 21:59

那如果享用呢?
venumars
帖子: 59
注册时间: 2007-10-15 20:03
送出感谢: 0
接收感谢: 0

#6

帖子 venumars » 2007-12-03 18:25

本来就是禁止的,那个值是 0
但是还是回出现那种情况,我都是这样的,不知道怎么办?
venumars
帖子: 59
注册时间: 2007-10-15 20:03
送出感谢: 0
接收感谢: 0

#7

帖子 venumars » 2007-12-03 18:34

我已经解决了。


首先确定驱动安装正确:
fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X300/X550/X1050 Series
OpenGL version string: 2.0.6473 (8.37.6)

以上信息表示ati的驱动安装好了

然后确定3d特效打开
glxinfo | grep direct
direct rendering: Yes

先试着打开特效

最初提示:"The Composite extension is not available"

于是在 etc/X11/xorg.conf里设置
Section “Extensions”
Option “Composite” “Enable”
EndSection

然后的提示信息是:
"Desktop effects could not be enabled"

查找论坛, 找到一个答案:要安装xserver-xgl, 安装好后, 特效果然可以开。
sudo apt-get install xserver-xgl



完了之后要重启,然后就可以用桌面效果了。
回复

回到 “老旧版本支持”