[问题]scim冲突问题按照快速设置指南中的做法仍然无法解决,哭了

为当前最终发行版之前的所有版本提供支持
回复
fishfree
帖子: 53
注册时间: 2007-04-20 11:05
送出感谢: 0
接收感谢: 0

[问题]scim冲突问题按照快速设置指南中的做法仍然无法解决,哭了

#1

帖子 fishfree » 2007-04-30 15:22

将scim改成scim-bridge后,openoffice是可以使用了,但是scim自身不能使用了,按Ctrl+Space切换不过来输入法,鼠标切换也不行。只好换回scim,但oo又不行了。
而且每次更改scim的配置之后得要重启系统之后才能见效,效率真底。
各位大大们有什么好办法吗?
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zmcbb30 » 2007-04-30 16:16



linux下改设置,通常重启程序就可以了(通常杀死进程)

代码: 全选

sudo killall -9 scim
scim
当然,你喜欢重启系统也没人会去拦你的,效果也还可以,重启了系统当然也会重启scim的了,所有程序都会重启

实在没办法的装fcitx代替scim
没必要这么死心眼
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
fishfree
帖子: 53
注册时间: 2007-04-20 11:05
送出感谢: 0
接收感谢: 0

#3

帖子 fishfree » 2007-05-07 7:29

谢谢,看样子我是得要尝试fcix了
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#4

帖子 依寻依然 » 2007-05-07 10:38

方法一:换fcitx
方法二:继续用你的scim,oo的问题这么解决:编辑/etc/gtk-2.0/gtk.immodules,注释掉以下两句:

代码: 全选

"/usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" ""
Borders are meant to be crossed
Nakedpig
帖子: 154
注册时间: 2006-06-28 21:53
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Nakedpig » 2007-05-13 14:49

注释掉/etc/gtk-2.0/gtk.immodules下的
"/usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" ""

应该能解决问题,你注释之前有没有把先前弄的修改更正过来?
/etc/X11/xinit/xinput.d/scim你看看这个文件有没有改回来了,重启试试。还有Feisty下好像是不能装scim-bridge的,装了会有冲突,用不了
fishfree
帖子: 53
注册时间: 2007-04-20 11:05
送出感谢: 0
接收感谢: 0

#6

帖子 fishfree » 2007-05-16 21:46

依照两位指示,久违的oo终于出来了。感谢!
回复

回到 “老旧版本支持”