怎么把C开发工具都装?

为当前最终发行版之前的所有版本提供支持
回复
头像
jessinio
帖子: 26
注册时间: 2006-10-19 16:55
送出感谢: 0
接收感谢: 0
联系:

怎么把C开发工具都装?

#1

帖子 jessinio » 2007-04-30 17:51

刚装上ubuntu7,我想编译一个软件,可以发现没有很多工具,如:gcc,make等。


请问怎么才能方便全都apt-get回来呢??
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 hualang0929 » 2007-04-30 17:56

aptitude install build-essential automake automake1.9
抬头望星空一片晴,我独行,夜已渐寒……
头像
jessinio
帖子: 26
注册时间: 2006-10-19 16:55
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jessinio » 2007-04-30 18:04

看了一下,大家都很喜欢用aptitude,为什么不用apt-get呢?
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#4

帖子 stlxv » 2007-04-30 18:45

jessinio 写了:看了一下,大家都很喜欢用aptitude,为什么不用apt-get呢?
为什么不用新立得软件包管理器呢
PHP是最好的语言!不服来战!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 hualang0929 » 2007-04-30 19:09

stlxv 写了:为什么不用新立得软件包管理器呢
慢呵
抬头望星空一片晴,我独行,夜已渐寒……
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 hualang0929 » 2007-04-30 19:14

jessinio 写了:看了一下,大家都很喜欢用aptitude,为什么不用apt-get呢?
我也不清楚,有人说在处理包依赖时aptitude好一点,我没发现哦,习惯而已。
等待高手来回答~~
抬头望星空一片晴,我独行,夜已渐寒……
头像
migney
帖子: 6
注册时间: 2007-04-06 16:45
送出感谢: 0
接收感谢: 0

#7

帖子 migney » 2007-04-30 19:28

sudo apt-get install manpages-dev
安装C语言函数的Man文件

sudo apt-get install build-essential
完成gcc,g++,make的安装

sudo apt-get install libc6-dev libstdc++6-4.0-dev
Include&lib

sudo apt-get install autoconf automake1.9
安装autoconf automake1.9

sudo apt-get install binutils-doc cpp-doc gcc-4.0-doc gcc-doc glibc-doc libstdc++6-4.0-doc stl-manual cpp-4.0-doc
安装文档

sudo apt-get install flex bison
安装flex和bison
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 hualang0929 » 2007-04-30 19:36

不用这么麻烦
装build-essential时就装了autoconf,gcc,g++,make等
再装automake就可以了
抬头望星空一片晴,我独行,夜已渐寒……
回复

回到 “老旧版本支持”