[help]关于berly的崩溃问题 希望大家帮帮忙

为当前最终发行版之前的所有版本提供支持
回复
头像
seabean
帖子: 152
注册时间: 2007-04-16 23:15
送出感谢: 0
接收感谢: 0

[help]关于berly的崩溃问题 希望大家帮帮忙

#1

帖子 seabean » 2007-04-30 19:46

成功安装beryl后 运行良好,今天想试一试beryl有什么新的玩法,结果点击面板的beryl图标 在渲染模式等等的那几项选择了强制 XGL ,结果 整个桌面就没有反应了,鼠标可以动,但是不能有任何操作.....
重启,结果登录后,连面板都没有出来,只有一张 素色的壁纸和鼠标在那里

没有办法,进入安全模式,用新立得把beryl卸载了..重启,进入普通帐户模式,把beryl重新安装了一次,结果一运行beryl 又变成了 上面所说的那种情况...

再次重启 进入安全模式 以root身份 执行 sudo apt-get remove beryl beryl-manager
重启进入普通帐户模式 重新安装beryl,beryl-manager,结果运行beryl又出现那种情况,整个桌面没有反应了,按住ctrl+alt+F8 也没有我帐户名出现...郁闷

我想不通,我以root身份 remove 掉beryl 然后重新 安装 ,以前的设置 怎么还在阿? 为什么没有回到beryl的默认设置呢?

现在不敢装了......是不是以前的设置保存在 / 下的那个文件里面 需要删除? 然后重新安装?
请大家帮帮忙,不想为了beryl而重装...谢谢
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#2

帖子 Decease » 2007-04-30 20:07

尝试删除.beryl文件
头像
seabean
帖子: 152
注册时间: 2007-04-16 23:15
送出感谢: 0
接收感谢: 0

#3

帖子 seabean » 2007-04-30 20:11

Decease 写了:尝试删除.beryl文件
谢谢 :P
----------------------

删除后,beryl打开后,桌面没有出现我在一楼所说的没有反应的情况,现在beryl的设置还是Metacity(Gnome窗口管理器)

我现在还不敢应用betyl的效果....

在高级beryl选项里面 “渲染平台”“绑定” “渲染”三个选项 还是选择的“强制XGL”,刚刚打开就是如此,并非我重新设置过
我想是不是这样 我删除了 隐藏文件.beryl,导致上面的选项无法生效?

请问 强制XGL为什么会导致 桌面没有反应呢?

如果我现在要使用beryl效果 是不是应该把“渲染平台”“绑定” “渲染”三个选项还原成 “自动”?
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#4

帖子 stlxv » 2007-04-30 20:50

要删的东西都在你的家目录下,有:

代码: 全选

.beryl/           .beryl-managerrc      .emerald/
估计就这些,总之清干净了就行了

你用apt泄载的时候加上--purge也会把配置文件删除
PHP是最好的语言!不服来战!
头像
seabean
帖子: 152
注册时间: 2007-04-16 23:15
送出感谢: 0
接收感谢: 0

#5

帖子 seabean » 2007-04-30 20:54

stlxv 写了:要删的东西都在你的家目录下,有:

代码: 全选

.beryl/           .beryl-managerrc      .emerald/
估计就这些,总之清干净了就行了

你用apt泄载的时候加上--purge也会把配置文件删除
谢谢 stlxv
现在beryl可以运行了
我想知道 强制XGL代表什么意思?高级beryl选项里面的那些东东 我上网google了一下 答案都不是很满意,有的还扯到照相机了....晕
头像
skyforum
帖子: 54
注册时间: 2007-04-19 1:37
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 skyforum » 2007-05-04 0:34

那个命令似乎不能把配置文件删除的,我好像在那里看过关于这个命令的详解
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#7

帖子 jarlyyn » 2007-05-04 0:37

beryl是个前端程序

他需要调用背后的图形api来实现他的效果

就如同一般游戏需要调用opengl或者directX一样

linux下常用的api有三种
aixgl,就是xorg新版中自带的。所以ubuntu的默认安装有
Nvidia,nvidia linux 驱动提供的
XGL,需要自己安装

你没安装XGL,却强制使用XGL.你觉得会怎么样呢?
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2007-05-04 1:11

seabean 写了:
stlxv 写了:要删的东西都在你的家目录下,有:

代码: 全选

.beryl/           .beryl-managerrc      .emerald/
估计就这些,总之清干净了就行了

你用apt泄载的时候加上--purge也会把配置文件删除
谢谢 stlxv
现在beryl可以运行了
我想知道 强制XGL代表什么意思?高级beryl选项里面的那些东东 我上网google了一下 答案都不是很满意,有的还扯到照相机了....晕
这个……简单地说,就是强制使用XGL来实现的意思咯。
PHP是最好的语言!不服来战!
applnk
帖子: 1485
注册时间: 2007-02-13 15:24
来自: 地球
送出感谢: 0
接收感谢: 0

#9

帖子 applnk » 2007-05-04 1:43

stlxv 写了:
seabean 写了:
stlxv 写了:要删的东西都在你的家目录下,有:

代码: 全选

.beryl/           .beryl-managerrc      .emerald/
估计就这些,总之清干净了就行了

你用apt泄载的时候加上--purge也会把配置文件删除
谢谢 stlxv
现在beryl可以运行了
我想知道 强制XGL代表什么意思?高级beryl选项里面的那些东东 我上网google了一下 答案都不是很满意,有的还扯到照相机了....晕
这个……简单地说,就是强制使用XGL来实现的意思咯。
说了等于没说。 :lol:
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#10

帖子 stlxv » 2007-05-04 9:52

applnk 写了:
stlxv 写了:
seabean 写了:
stlxv 写了:要删的东西都在你的家目录下,有:

代码: 全选

.beryl/           .beryl-managerrc      .emerald/
估计就这些,总之清干净了就行了

你用apt泄载的时候加上--purge也会把配置文件删除
谢谢 stlxv
现在beryl可以运行了
我想知道 强制XGL代表什么意思?高级beryl选项里面的那些东东 我上网google了一下 答案都不是很满意,有的还扯到照相机了....晕
这个……简单地说,就是强制使用XGL来实现的意思咯。
说了等于没说。 :lol:
:em24 本来就是这个意思嘛 :em27
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”