rpm不能正常使用

为当前最终发行版之前的所有版本提供支持
回复
tmp
帖子: 126
注册时间: 2007-04-27 22:24
送出感谢: 0
接收感谢: 0
联系:

rpm不能正常使用

#1

帖子 tmp » 2007-04-30 21:00

如下的error,看样子是某些包没有安装。但是有一个提示,说libICE.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
但我在更新软件中没有找到该包,只有libice6包,不过我已安装该包了。
请问是怎么回事啊?
谢谢!


root@root:~/Desktop# rpm -ivh gaim-2.0.0-1.beta6.fc5.x86_64.rpm
warning: gaim-2.0.0-1.beta6.fc5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 4c292fcc
error: 依赖性检测失败:
/bin/bash 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
/bin/sh 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
/sbin/ldconfig 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
/usr/bin/python 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libICE.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libORBit-2.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libSM.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libX11.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libXext.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libXss.so.1()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libaspell.so.15()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libatk-1.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libbonobo-2.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libbonobo-activation.so.4()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libc.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libc.so.6(GLIBC_2.2.5)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libc.so.6(GLIBC_2.3)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libc.so.6(GLIBC_2.3.4)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libc.so.6(GLIBC_2.4)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libcairo.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libcrypt.so.1()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libcrypto.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libdbus-1.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libdbus-glib-1.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libdl.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libdl.so.2(GLIBC_2.2.5)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libebook-1.2.so.5()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libedata-book-1.2.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libedataserver-1.2.so.7()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgadu.so.3()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgconf-2.so.4()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgdk-x11-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgdk_pixbuf-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libglib-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgmodule-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgnome-2.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgnomevfs-2.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgobject-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgstreamer-0.10.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgthread-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgtk-x11-2.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libgtkspell.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libm.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libm.so.6(GLIBC_2.2.5)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libnsl.so.1()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libnspr4.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libnss3.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libnss3.so(NSS_3.2)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libnss3.so(NSS_3.3)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libpango-1.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libpangocairo-1.0.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libperl.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libplc4.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libplds4.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libpopt.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libpthread.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libpthread.so.0(GLIBC_2.2.5)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libresolv.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libresolv.so.2(GLIBC_2.2.5)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libsasl2.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libsmime3.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libssl.so.6()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libssl3.so()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libssl3.so(NSS_3.2)(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libstartup-notification-1.so.0()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libutil.so.1()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libxml2.so.2()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
libz.so.1()(64bit) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl >= 0:5.008 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(AutoLoader) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(Carp) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(Exporter) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(XSLoader) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(strict) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
perl(warnings) 被 gaim-2.0.0-1.beta6.fc5.x86_64 所需要
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#2

帖子 Element » 2007-05-04 8:55

要deb的包,dpkg -i *.deb来安装
rpm的要先转换成deb再安装,alien转换,不建议在ubuntu上用rpm的包。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
Chine
帖子: 204
注册时间: 2006-12-22 21:50
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Chine » 2007-05-04 9:30

在linux系统的软件中,有很多是rpm的,这种软件包在Ubuntu不能直接使用,若真的要使用,那要把rpm包转换成deb包

(1)装个将rpm包转换为deb包的小工具alien

apt-get install alien

(2)进入rpm所在的目录,输入命令

alien xxx.rpm(转换为deb包的rpm文件)
tmp
帖子: 126
注册时间: 2007-04-27 22:24
送出感谢: 0
接收感谢: 0
联系:

谢谢了

#4

帖子 tmp » 2007-05-04 11:07

多谢大虾们。
flamingwind
帖子: 26
注册时间: 2007-03-01 17:43
送出感谢: 0
接收感谢: 0

#5

帖子 flamingwind » 2007-05-24 20:18

可以在新德里里安装支持rpm的环境
很方便的
打开 输入rpm标记安装就好了
回复

回到 “老旧版本支持”