当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装开发包求助
帖子发表于 : 2007-05-01 1:07 

注册: 2006-10-14 20:50
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
想安装mysql-devel
出现

root@mdj-ubuntu:~/py/MySQL-python-1.2.1# apt-get install mysql-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mysql-devel is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libmysqlclient12-dev libmysqlclient12 libmysqlclient10-dev libmysqlclient10
E: Package mysql-devel has no installation candidate
root@mdj-ubuntu:~/py/MySQL-python-1.2.1#


请问这个是什么意思? 是需要安装 libmysqlclient12-dev 这几个包才才可以么?

我尝试apt-get install libmysqlclient10的时候出现

root@mdj-ubuntu:~/py/MySQL-python-1.2.1# apt-get install libmysqlclient10
Reading package lists... Done
Building dependency tree
Reading state information... Done
libmysqlclient10 is already the newest version.
The following packages were automatically installed and are no longer required:
libgnadeodbc1.6 libgnatvsn4.1 libgnadeodbc-dev haskell-utils libgmp3-dev
libgmpxx4 unixodbc libghc6-hsql-dev libreadline5-dev libgmp3c2
odbcinst1debian1 libgnatprj4.1 ghc6 libmysqlclient12 libgnademysql1.6
gnat-4.1 gnat-4.1-base libltdl3 libgnat-4.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 34 not upgraded.

是不是应该运行apt-get autoremove?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-04 1:34 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
我的新立得软件包管理器根本没找到这个东西,lz想做什么呢?为什么不直接用新立得软件包管理器呢?


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译