[问题]请教mplayer字幕加载问题

为当前最终发行版之前的所有版本提供支持
回复
slong42
帖子: 54
注册时间: 2006-10-25 18:37
送出感谢: 0
接收感谢: 0

[问题]请教mplayer字幕加载问题

#1

帖子 slong42 » 2007-05-05 10:33

大家在使用mpalyer加载字幕时有没有遇到乱码的情况啊。我看越狱高清版时,电影是mkv格式的,内嵌的字幕没法显示,然后我再用外挂字幕,格式是ass,但也不能加载,我尝试过将ass字幕编码转成UTF-8的,但显示出来是乱码,不知道怎么办好,同样的rmvb内嵌字幕的就没有这个问题。
还有我在看怪物史瑞克的时候也有这样的问题,avi电影,srt字幕,字幕不能加载,转成utf-8后是乱码。
现在我有点不知所措了。
字体我设的Unicode,,上面的路径我给的雅黑
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zmcbb30 » 2007-05-05 11:53

应该是字幕的字体跟你的雅黑不同,所以乱码

试试指定其他字体
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
stufever
帖子: 69
注册时间: 2007-03-11 17:48
送出感谢: 0
接收感谢: 0

#3

帖子 stufever » 2007-05-05 22:17

在~/.mplayer/config里边加入下边几行试试
subcp=cp936
subfont-autoscale=2
subfont-text-scale=3
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#4

帖子 hcym » 2007-05-06 9:42

似乎ubuntu看高清的不多,唉

知音难觅啊
slong42
帖子: 54
注册时间: 2006-10-25 18:37
送出感谢: 0
接收感谢: 0

#5

帖子 slong42 » 2007-05-06 19:53

stufever 写了:在~/.mplayer/config里边加入下边几行试试
subcp=cp936
subfont-autoscale=2
subfont-text-scale=3


请问这几行是什么意思呢。。我加入后和之前一样的结果?
slong42
帖子: 54
注册时间: 2006-10-25 18:37
送出感谢: 0
接收感谢: 0

#6

帖子 slong42 » 2007-05-06 19:54

zmcbb30 写了:应该是字幕的字体跟你的雅黑不同,所以乱码

试试指定其他字体

我换其它的字体也是一样的。
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

#7

帖子 tommy007 » 2007-05-06 19:59

和字体无关,MKV就算选正确的编码,如果内封的是ssa字幕。也可能出现一部分乱码一部分正常的现象。

编码的设定是,字体选项卡里面设置为unicode,前面设置成CP936。

另外,自动加载字幕只在文件主名完全相同的时候才会。不接受AIR 第03話 「こえ -whisper-」 [1024x576 x264].tc.ssa
这样的自动加载= =他只认AIR 第03話 「こえ -whisper-」 [1024x576 x264].ssa

MKV内嵌字幕需要手工按J按键进行切换。如果不自动挂字幕也可以用菜单手选一个。
slong42
帖子: 54
注册时间: 2006-10-25 18:37
送出感谢: 0
接收感谢: 0

#8

帖子 slong42 » 2007-05-07 16:32

楼上说的是ssa,那我如果是ass的呢?
能否看看我的设置是否正确?

还有请问有没有看yytes出品的。内嵌字幕MKV格式的越狱?
附件
Screenshot-Preferences.png
Screenshot-Preferences-1.png
xblx
帖子: 274
注册时间: 2006-12-18 1:05
送出感谢: 0
接收感谢: 0

#9

帖子 xblx » 2007-05-07 20:23

美剧通常看RMVB, AVI也下,rmvb还没出的话
gzd900
帖子: 176
注册时间: 2005-12-14 4:37
来自: 十堰
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 gzd900 » 2007-05-07 23:52

在UBUNTU下看高清晰电影最好安装VLC,字幕选/usr/share/fonts/truetype/arphic/ukai.ttf就可以了,我一直就这样,没有出现过乱码。如果在看TP、TS格式电影时有水波纹出现,可以点右键选“解除交错”项的Bob或丢弃即可解决。
slong42
帖子: 54
注册时间: 2006-10-25 18:37
送出感谢: 0
接收感谢: 0

#11

帖子 slong42 » 2007-05-08 0:12

谢谢,终于解决了。是字体的关系。谢谢gzd900,谢谢大家
回复

回到 “老旧版本支持”