[分享]编译时常需要的一些库开发包

为当前最终发行版之前的所有版本提供支持
回复
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

[分享]编译时常需要的一些库开发包

#1

帖子 anticlockwise » 2007-05-06 12:20

看到许多人经常会问在./configure的时候会提示类似:

代码: 全选

configure: error:
You must have the GTK+ 2.0 development headers installed to compile Pidgin. 
的错误信息,不要急,这只是因为你缺少了需要的dev包而已,以下是一些编译时常用的dev包,都可以用apt-get install获得

提示类似:You must have the GTK+ 2.0 development headers installed错误信息时:
libgtk2.0-dev

提示类似:configure:error:unable to find Boost.DateTime library, currently this is required.时:
libboost-date-time-dev

提示类似:configure:error:unable to find Boost library, currently this is required.时:
libboost-dev

提示类似:configure:error:unable to find Boost.Serialization library, currently this is required.时:
libboost-serialization-dev

提示类似:configure:error:Can't find X libraries时:
kdebase-dev

提示类似:configure:error:Can't find QT...时:
libqt3-mt-dev

提示类似:Couldn't find libXmu in LD_LIBRARY_PATH, checking X11 paths
libxmu-dev

目前就想到这么多,希望大家多补充,这样能方便大家编译
最终完美体
帖子: 170
注册时间: 2007-03-17 15:30
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 最终完美体 » 2007-05-06 12:43

顶~
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 anticlockwise » 2007-05-06 17:44

提示类似:configure:error:Couldn't find SSL libraries:(如pidgin,jabbin等网络程序)
libssl-dev
头像
vbem
帖子: 239
注册时间: 2006-09-13 9:09
送出感谢: 0
接收感谢: 0

#4

帖子 vbem » 2007-05-06 19:25



一般编译时少什么再装
今天NUPT以我为耻
明天我以NUPT为耻
james.lee
帖子: 24
注册时间: 2006-12-07 18:58
送出感谢: 0
接收感谢: 0

#5

帖子 james.lee » 2007-05-19 21:09

顶,对我这种菜鸟比较有用
xblx
帖子: 274
注册时间: 2006-12-18 1:05
送出感谢: 0
接收感谢: 0

Re: [分享]编译时常需要的一些库开发包

#6

帖子 xblx » 2007-05-19 23:27

anticlockwise 写了:
提示类似:configure:error:Can't find QT...时:
libqt3-mt-dev
安装KDE一主题包,遇到QT错误,但安装不了libqt3-mt-dev啊:

代码: 全选

$ sudo apt-get install libqt3-mt-dev
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libqt3-mt-dev: 依赖: libfontconfig1-dev 但是它将不会被安装
                 依赖: libfreetype6-dev 但是它将不会被安装
                 依赖: libxft-dev 但是它将不会被安装
E: 无法安装的软件包
lizezhigrass
帖子: 6
注册时间: 2011-10-07 12:47
送出感谢: 0
接收感谢: 0

Re: [分享]编译时常需要的一些库开发包

#7

帖子 lizezhigrass » 2012-09-13 21:39

回6楼:
sudo apt-get install libfontconfig1-dev libfreetype6-dev libxft-dev
回复

回到 “老旧版本支持”