[问题]安装显卡驱动的错误[solved]

为当前最终发行版之前的所有版本提供支持
回复
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

[问题]安装显卡驱动的错误[solved]

#1

帖子 wzyiam » 2007-05-08 12:02

我关了X,安装显卡驱动。
提示:unable to find the kernel source tree for the currently running kernel.
什么意思?谢谢
上次由 wzyiam 在 2007-05-13 18:55,总共编辑 1 次。
头像
oydl82
帖子: 1073
注册时间: 2006-09-04 21:38
来自: 中国沙大
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 oydl82 » 2007-05-08 12:18

好象是有关内核的库没有安装,试试到新得立去找找kernel-dev之类的东西。
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wzyiam » 2007-05-08 12:41

提示:no precompiled kernel interface was found to match your kernel.
the installer will need to compile a interface for your kernel.
是不是叫我编译内核?可是我不会阿!
头像
oydl82
帖子: 1073
注册时间: 2006-09-04 21:38
来自: 中国沙大
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 oydl82 » 2007-05-08 12:47

关注高手解决
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wzyiam » 2007-05-08 12:48

谢谢你兄弟,啥和别说了……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-05-08 12:58

$● aw nvidia-glx
软件包: nvidia-glx
状态: 已安装
自动安装: 否
版本号: 1.0.9755+2.6.20.4-13.14
优先级: 可选
部分: restricted/misc
维护者: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
未压缩尺寸: 14.8M
依赖于: nvidia-kernel-1.0.9755, linux-restricted-modules-common, xserver-xorg-core
(>= 1:0.99.0-1), libglu1-mesa | libglu1, libatk1.0-0 (>= 1.13.1), libc6
(>= 2.5-0ubuntu1), libglib2.0-0 (>= 2.12.9), libgtk2.0-0 (>= 2.10.3),
libpango1.0-0 (>= 1.16.1), libx11-6, libxext6
建议: nvidia-kernel-source (>= 1.0.9755)
冲突: nvidia-glx-src, nvidia-settings, nvidia-xconfig
代替: nvidia-glx-src
提供: xserver-xorg-video
提供者:: nvidia-glx-legacy, nvidia-glx-new
描述: NVIDIA binary XFree86 4.x/X.Org driver
These XFree86 4.x/X.Org binary drivers provide optimized hardware acceleration of
OpenGL applications via a direct-rendering X Server and support the newer GeForce,
nForce and Quadro families of NVIDIA chipsets. AGP, TV-out and flat panel displays
are also supported.

If you have a TNT, TNT2, or older GeForce, you may need the nvidia-glx-legacy
package instead of this one.

To enable the driver, run "sudo nvidia-glx-config enable".

i linux-restricted-modules-2.6.20-13-generic - Non-free Linux 2.6.20 modules on x86/x86_64
i linux-headers-2.6.20-13 - Header files related to Linux kernel versi
i linux-headers-2.6.20-13-generic - Linux kernel headers for version 2.6.20 on
i linux-image-2.6.20-13-generic - Linux kernel image for version 2.6.20 on x

和内核版本对应的这些,你看你的少了什么。
● 鸣学
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 wzyiam » 2007-05-08 13:02

非常感谢,我先研究研究,因为我好像还不懂这些。再次感谢!
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 wzyiam » 2007-05-08 18:35

兄弟,能不能告诉我怎么看阿,还是没研究出来。
回复

回到 “老旧版本支持”