[问题]broadcom 4311 无线网卡速度慢怎么解决?

为当前最终发行版之前的所有版本提供支持
回复
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

[问题]broadcom 4311 无线网卡速度慢怎么解决?

#1

帖子 zjumty » 2007-05-08 22:17

用wiki上的方法把我的无线网卡(ASUS的F5R,芯片BCM4311)装上了,可是速度特别慢,最大只能达到14k/s。这速度根本没法用阿。

用iwconfig eth0 rate 54M后,虽然变成了54M,速度还是慢,一重新连接又回到了11M。

大家有没有遇到这种情况的? 怎么解决阿?

无连接状态

terry@terry-laptop:~/download$ iwconfig eth0
eth0 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4311"
Mode:Managed Frequency=2.484 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

有连接状态

terry@terry-laptop:~/download$ iwconfig eth0
eth0 IEEE 802.11b/g ESSID:"TP-LINK" Nickname:"Broadcom 4311"
Mode:Managed Frequency=2.437 GHz Access Point: 00:14:78:68:CF:AC
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality=76/100 Signal level=-48 dBm Noise level=-71 dBm
Rx invalid nwid:0 Rx invalid crypt:26 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-05-08 22:24

Rx invalid crypt:26
有问题啊。
Frequency还变化的??
iwlist eth0 rate里面不会有这2种频率吧。
● 鸣学
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

#3

帖子 zjumty » 2007-05-08 22:29

terry@terry-laptop:~/download$ iwlist eth0 rate
eth0 12 available bit-rates :
0.012 kb/s
0.018 kb/s
0.024 kb/s
0.036 kb/s
0.048 kb/s
0.072 kb/s
0.096 kb/s
0.108 kb/s
0.002 kb/s
0.004 kb/s
0.011 kb/s
0.022 kb/s
Current Bit Rate=1 Mb/s

好像很有问题阿
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#4

帖子 jarlyyn » 2007-05-08 23:16

4311,用的非官方linux驱动的话只能到11m

lz是用的linux驱动还是ndiswrapper驱动?
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

#5

帖子 zjumty » 2007-05-09 13:10

我用的是ndiswrapper
官方有linux驱动吗?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#6

帖子 jarlyyn » 2007-05-09 13:19

那估计是你信号太差?
头像
ulcer
帖子: 50
注册时间: 2006-10-23 14:46
送出感谢: 0
接收感谢: 0

#7

帖子 ulcer » 2007-05-09 20:19

按照wiki里的方法安装ndiswrapper 驱动,无线网卡应该是wlan0吧?为何lz的是eth0?
老机器也跑Ubuntu~
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

#8

帖子 zjumty » 2007-05-09 21:49

信号应该不差,因为在windows下可以达到54M。

是很奇怪,没有wlan0这个设备,我用的是ubuntu7.04。

大家的4311没这个问题吗?
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#9

帖子 jarlyyn » 2007-05-09 23:13

我就觉得你应该用的还是linux驱动

你把原来那个驱动屏蔽了没?
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

#10

帖子 zjumty » 2007-05-10 21:43

linux驱动在哪里能找到啊,我上网搜了一下,都是用ndiswrapper的。
头像
choukuangjay
帖子: 274
注册时间: 2006-01-17 14:39
来自: Nanking
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 choukuangjay » 2007-05-11 21:56

ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营
webnoise
帖子: 12
注册时间: 2008-01-18 9:29
送出感谢: 0
接收感谢: 0

#12

帖子 webnoise » 2008-01-26 8:34

我的电脑显示36Mbps
参照这个链接吧http://forum.ubuntu.org.cn/viewtopic.php?p=611354
头像
zjumty
帖子: 47
注册时间: 2006-05-14 23:07
送出感谢: 0
接收感谢: 0

#13

帖子 zjumty » 2008-01-26 11:40

webnoise 写了:我的电脑显示36Mbps
参照这个链接吧http://forum.ubuntu.org.cn/viewtopic.php?p=611354
现在换成7.10,已经完全没问题了!
回复

回到 “老旧版本支持”