[问题]还是我,jdk环境变量设置

为当前最终发行版之前的所有版本提供支持
回复
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

[问题]还是我,jdk环境变量设置

#1

帖子 wzyiam » 2007-05-08 22:33

我当网上去找了找,是在.bashrc中添加

代码: 全选

export JAVA_HOME=/usr/java/j2sdk1.4.2_04
export CLASSPATH=$CLASSPATH:$JAVA_HOME/lib:$JAVA_HOME/jre/lib
export PATH=$JAVA_HOME/bin:$JAVA_HOME/jre/bin:$PATH:$HOMR/bin
不是到对不对,问下大家。
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#2

帖子 依寻依然 » 2007-05-08 22:34

classpath前面最好加点
Borders are meant to be crossed
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wzyiam » 2007-05-08 22:37

试了,没成功。其实就是运行XXX.java的时候出现Exception in thread "main" java.lang.NoSuchMethodError: main
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#4

帖子 依寻依然 » 2007-05-08 22:50

代码: 全选

export JAVA_HOME=/usr/lib/jvm/java-6-sun
export CLASSPATH=.:$JAVA_HOME/lib
export PATH=$PATH:$JAVA_HOME/bin
这是我的,你自己对照路径修改一下,那个点一定要加

最好在/etc/environment中也加上
Borders are meant to be crossed
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wzyiam » 2007-05-08 23:11

我觉得你这个会准确点,网上的好像是redhat的
mailman
帖子: 51
注册时间: 2005-12-13 19:40
送出感谢: 2 次
接收感谢: 0
联系:

#6

帖子 mailman » 2007-05-09 0:39

如果你是运行的话。java xxx 后面没有扩展名
如果是编译的话。 javac xxx.java 有扩展名
检查一下你的命令吧 估计是运行时 加扩展名了。
头像
wzyiam
帖子: 161
注册时间: 2007-04-26 11:41
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 wzyiam » 2007-05-09 8:04

我运行的时候是没有加扩展名的。还是不行
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2007-05-09 11:17

wzyiam 写了:试了,没成功。其实就是运行XXX.java的时候出现Exception in thread "main" java.lang.NoSuchMethodError: main
XXX.java是根本就不能运行的,要先编译成.class才能运行

另外,那些什么变量什么的根本不需要设置,除非你用tomcat它要求你JAVA_HOME才需要;你试试把这些设置全都去掉,说不定你的程序就能运行了,不信可以试试

另外,你运行的时候的错误是缺少main这个方法,这是你程序自己的问题,没有main方法的程序是不能被启动运行的
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”