[问题]5.10 无法安装proe??? 求助 (已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
abcdo
帖子: 233
注册时间: 2005-10-29 9:16
送出感谢: 0
接收感谢: 0

[问题]5.10 无法安装proe??? 求助 (已解决)

#1

帖子 abcdo » 2005-10-31 16:31

用的刻的光盘
按照论坛帖子一步一步作的,但到了下面就!!,好象是无法得到正确uname
返回值

zlgoo@zlgoo:/cdrom$ sudo ./setup
sudo: unable to execute ./setup: Permission denied
zlgoo@zlgoo:/cdrom$ sudo sh setup
setup: /cdrom/getpmt.csh: /bin/csh: bad interpreter: Permission denied

Starting PTC.Setup, please wait ...
ERROR: /cdrom/dsrc//obj/ptcsetup - file is missing.
Check the name of the CD mount directory.
上次由 abcdo 在 2005-11-04 9:05,总共编辑 1 次。
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#2

帖子 Tenyears » 2005-10-31 18:03

setup: /cdrom/getpmt.csh: /bin/csh: bad interpreter: Permission denied

sudo apt-get install csh
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 gnix_oag » 2005-10-31 18:50

sudo apt-get install csh
头像
abcdo
帖子: 233
注册时间: 2005-10-29 9:16
送出感谢: 0
接收感谢: 0

[问题]

#4

帖子 abcdo » 2005-11-01 4:28

zlgoo@zlgoo:~$ LANG=EN
zlgoo@zlgoo:~$ cd /cdrom
zlgoo@zlgoo:/cdrom$ ls
MAGNiTUDE dsrc getpmt.csh html ptc_inst ptcsh0 setup uninstall
zlgoo@zlgoo:/cdrom$ sudo ./setup
Password:
sudo: unable to execute ./setup: Permission denied
zlgoo@zlgoo:/cdrom$ sudo apt-get install csh
Reading package lists... Done
Building dependency tree... Done
csh is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
zlgoo@zlgoo:/cdrom$

zlgoo@zlgoo:/cdrom$ sudo sh setup
setup: /cdrom/getpmt.csh: /bin/csh: bad interpreter: Permission denied

Starting PTC.Setup, please wait ...
ERROR: /cdrom/dsrc//obj/ptcsetup - file is missing.
Check the name of the CD mount directory.
zlgoo@zlgoo:/cdrom$
头像
abcdo
帖子: 233
注册时间: 2005-10-29 9:16
送出感谢: 0
接收感谢: 0

[分享]解决很简单!

#5

帖子 abcdo » 2005-11-02 0:51

不管 csh了,直接修改 getpmt.csh,简化为
如下,安装成功,感觉好象不是csh的问题,大家解释一下吧,谢谢!!!

#!/bin/csh -f

##getpmt.csh修改,去掉多余判断

setenv LANG C

set id = "i486_linux"

echo $id
回复

回到 “老旧版本支持”