[问题]E: dpkg was interrupted, you must manually run 'dpkg --c

为当前最终发行版之前的所有版本提供支持
回复
huanhu
帖子: 10
注册时间: 2007-04-28 18:36
送出感谢: 0
接收感谢: 0

[问题]E: dpkg was interrupted, you must manually run 'dpkg --c

#1

帖子 huanhu » 2007-05-09 10:34

现在用UPDATE升级时候最后就会出现这个 E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
错误 ,是什么原因造成的呢
要怎么弄呢
huanhu
帖子: 10
注册时间: 2007-04-28 18:36
送出感谢: 0
接收感谢: 0

#2

帖子 huanhu » 2007-05-09 11:16

顶上去,让高手解决一下!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2007-05-09 11:31

提示信息里面就有解决方案。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
huanhu
帖子: 10
注册时间: 2007-04-28 18:36
送出感谢: 0
接收感谢: 0

#4

帖子 huanhu » 2007-05-09 11:49

有啊
可我不懂啊
要怎么搞啊
huanhu
帖子: 10
注册时间: 2007-04-28 18:36
送出感谢: 0
接收感谢: 0

#5

帖子 huanhu » 2007-05-09 16:14

顶上去。。。。。。。。。。。。。。
foresteast
帖子: 5
注册时间: 2007-12-17 22:38
送出感谢: 0
接收感谢: 0

#6

帖子 foresteast » 2007-12-17 22:40

sudo dpkg --configure -a
这个就足够用了
我也是这个问题
human.gold
帖子: 28
注册时间: 2007-07-05 9:06
送出感谢: 0
接收感谢: 0

#7

帖子 human.gold » 2008-07-31 10:00

foresteast 写了:sudo dpkg --configure -a
这个就足够用了
我也是这个问题
sudo dpkg --configure -a

long time too wait
human.gold
帖子: 28
注册时间: 2007-07-05 9:06
送出感谢: 0
接收感谢: 0

#8

帖子 human.gold » 2008-07-31 10:41

human.gold 写了:
foresteast 写了:sudo dpkg --configure -a
这个就足够用了
我也是这个问题
sudo dpkg --configure -a

long time too wait
and no message
zalpirin
帖子: 21
注册时间: 2007-10-13 20:38
送出感谢: 0
接收感谢: 0

#9

帖子 zalpirin » 2008-07-31 18:21

human.gold 写了:
human.gold 写了:
foresteast 写了:sudo dpkg --configure -a
这个就足够用了
我也是这个问题
sudo dpkg --configure -a

long time too wait
and no message
怎么解觉得这个问题,我等了很久了!
human.gold
帖子: 28
注册时间: 2007-07-05 9:06
送出感谢: 0
接收感谢: 0

#10

帖子 human.gold » 2008-08-05 16:09

zalpirin 写了:
human.gold 写了:
human.gold 写了:
foresteast 写了:sudo dpkg --configure -a
这个就足够用了
我也是这个问题
sudo dpkg --configure -a

long time too wait
and no message
怎么解觉得这个问题,我等了很久了!
我刚刚在老外的论坛上发现一个能解决的方法

相关地址如下https://answers.launchpad.net/ubuntu/+question/39877

这应该是 7.10 -8.04的 一个升级bug

------------------------------------------


--------------------------------
e文不好的 直接 如下操作

CTRL+ALT+F2 切换个 操作界面 直接输入以下 内容,权限不够的 记得加 Sudo


chmod 644 /usr/bin/localedef
killall locale-gen

然后执行

chmod 755 /usr/bin/localedef

-------------------------------------------------------
这时如果你已经执行的
apt-get dist-upgrade
dpkg --configure -a

的话, 应该之前是卡在 g en-AU.UTF-8 的, 那么现在 自己切换回去看看 应该已经可以更新了,
如果 之前没有 操作的话, 直接输入
apt-get dist-upgrade
dpkg --configure -a
应该可以了,之后的升级时间会很长 ,请大家耐心等待,中间 如果再出现类似的 某个语言包卡在那里不动的话,按照上面继续操作下。
最后装完 可能会缺不少 语言包。

目前我是发现 en_AU.UTF-8
zh_CH.UTF-8
装不上, 其他的暂时还没发现
------------下面是 原文 的 链接, e文可以的可以自己看-----------------------------------------------------
cirelle said on 2008-07-21:

I found this in the bugs area and it worked for me

Izzy wrote on 2008-07-17: (permalink)

I just ran into the same problem a few hours ago. Google brought me to the same sources as quoted above. "Compiling" the collected information, here is a work-around that did it for me (step-by-step - so everybody can solve it until the bug is fixed):

run the dist-upgrade as recommended. If the process hangs at generating locales, taking more than 20min for the first one and still not continuing:

chmod 644 /usr/bin/localedef
killall locale-gen

now the process should continue, but throwing a bunch of errors (simply ignore those). If it still not continues, check whether locale-gen has really been killed (ps aux|grep locale-gen) and repeat "killall locale-gen" until it's gone.

When update-manager is done, don't forget to

chmod 755 /usr/bin/localedef

For me, update-manager seemed to be able to finally solve the issue, there have been no more steps required after the above. But just to be sure:

Reboot to the normal grub option offered (i.e. the latest kernel just installed), but do not yet login graphically. Instead, press Ctrl-Alt-F1 to get a text console. Login there, and run

apt-get dist-upgrade
dpkg --configure -a

As just stated, in my case both were done within a second, simply stating there was nothing to do. Now you can logout here (type "exit" or press Ctrl-D), return to the graphical console (Alt-F7), and login. You are done.

Besides: I was really mad that the dist-upgrade forced me to install OpenOffice. I had it explicitly uninstalled, since it conflicts with StarOffice which I prefer. Luckily, I was able to simply uninstall OO again and there have been no side-effects left as far as I can tell up to now. The dist-upgrade should not just install stuff like that if it was not installed...
human.gold
帖子: 28
注册时间: 2007-07-05 9:06
送出感谢: 0
接收感谢: 0

#11

帖子 human.gold » 2008-08-05 16:21

最大的感触 , google 比啥都管用

还有不要放过 英文类的 资料, 往往 都是这些解决的
ycs211
帖子: 2
注册时间: 2008-08-05 0:18
送出感谢: 0
接收感谢: 0

#12

帖子 ycs211 » 2008-08-06 1:40

没灭掉
ycs211
帖子: 2
注册时间: 2008-08-05 0:18
送出感谢: 0
接收感谢: 0

#13

帖子 ycs211 » 2008-08-06 1:42

查了一天的英文地 没个解决的
human.gold
帖子: 28
注册时间: 2007-07-05 9:06
送出感谢: 0
接收感谢: 0

#14

帖子 human.gold » 2008-08-06 10:36

ycs211 写了:查了一天的英文地 没个解决的
chmod 644 /usr/bin/localedef
killall locale-gen



chmod 755 /usr/bin/localedef
d02540315
帖子: 1
注册时间: 2008-08-09 13:05
送出感谢: 0
接收感谢: 0

#15

帖子 d02540315 » 2008-08-09 13:06

human.gold 写了:
zalpirin 写了:
human.gold 写了:
human.gold 写了:
foresteast 写了:sudo dpkg --configure -a
这个就足够用了
我也是这个问题
sudo dpkg --configure -a

long time too wait
and no message
怎么解觉得这个问题,我等了很久了!
我刚刚在老外的论坛上发现一个能解决的方法

相关地址如下https://answers.launchpad.net/ubuntu/+question/39877

这应该是 7.10 -8.04的 一个升级bug

------------------------------------------


--------------------------------
e文不好的 直接 如下操作

CTRL+ALT+F2 切换个 操作界面 直接输入以下 内容,权限不够的 记得加 Sudo


chmod 644 /usr/bin/localedef
killall locale-gen

然后执行

chmod 755 /usr/bin/localedef

-------------------------------------------------------
这时如果你已经执行的
apt-get dist-upgrade
dpkg --configure -a

的话, 应该之前是卡在 g en-AU.UTF-8 的, 那么现在 自己切换回去看看 应该已经可以更新了,
如果 之前没有 操作的话, 直接输入
apt-get dist-upgrade
dpkg --configure -a
应该可以了,之后的升级时间会很长 ,请大家耐心等待,中间 如果再出现类似的 某个语言包卡在那里不动的话,按照上面继续操作下。
最后装完 可能会缺不少 语言包。

目前我是发现 en_AU.UTF-8
zh_CH.UTF-8
装不上, 其他的暂时还没发现
------------下面是 原文 的 链接, e文可以的可以自己看-----------------------------------------------------
cirelle said on 2008-07-21:

I found this in the bugs area and it worked for me

Izzy wrote on 2008-07-17: (permalink)

I just ran into the same problem a few hours ago. Google brought me to the same sources as quoted above. "Compiling" the collected information, here is a work-around that did it for me (step-by-step - so everybody can solve it until the bug is fixed):

run the dist-upgrade as recommended. If the process hangs at generating locales, taking more than 20min for the first one and still not continuing:

chmod 644 /usr/bin/localedef
killall locale-gen

now the process should continue, but throwing a bunch of errors (simply ignore those). If it still not continues, check whether locale-gen has really been killed (ps aux|grep locale-gen) and repeat "killall locale-gen" until it's gone.

When update-manager is done, don't forget to

chmod 755 /usr/bin/localedef

For me, update-manager seemed to be able to finally solve the issue, there have been no more steps required after the above. But just to be sure:

Reboot to the normal grub option offered (i.e. the latest kernel just installed), but do not yet login graphically. Instead, press Ctrl-Alt-F1 to get a text console. Login there, and run

apt-get dist-upgrade
dpkg --configure -a

As just stated, in my case both were done within a second, simply stating there was nothing to do. Now you can logout here (type "exit" or press Ctrl-D), return to the graphical console (Alt-F7), and login. You are done.

Besides: I was really mad that the dist-upgrade forced me to install OpenOffice. I had it explicitly uninstalled, since it conflicts with StarOffice which I prefer. Luckily, I was able to simply uninstall OO again and there have been no side-effects left as far as I can tell up to now. The dist-upgrade should not just install stuff like that if it was not installed...


10楼的方法 我试过了 解决问题了, 谢谢!
回复

回到 “老旧版本支持”