[已解决]编译的时候出现这样的错误怎么办?

为当前最终发行版之前的所有版本提供支持
回复
trarit
帖子: 30
注册时间: 2007-04-27 16:07
送出感谢: 0
接收感谢: 0

[已解决]编译的时候出现这样的错误怎么办?

#1

帖子 trarit » 2007-05-11 13:06

checking for MUSICAPPLET_DEPS... configure: error: Package requirements (
gtk+-2.0
libpanelapplet-2.0
pygtk-2.0
gnome-python-2.0
) were not met:

No package 'libpanelapplet-2.0' found
No package 'gnome-python-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MUSICAPPLET_DEPS_CFLAGS
and MUSICAPPLET_DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
貌似可以在环境变量里设置避免这个错误?
不大明鸟~
上次由 trarit 在 2007-05-11 17:06,总共编辑 1 次。
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 anticlockwise » 2007-05-11 13:08

缺什么就装什么:

sudo apt-get install libpanel-applet2-dev python-gnome2-dev
trarit
帖子: 30
注册时间: 2007-04-27 16:07
送出感谢: 0
接收感谢: 0

#3

帖子 trarit » 2007-05-11 17:05

谢谢,问题解决了
头像
choukuangjay
帖子: 274
注册时间: 2006-01-17 14:39
来自: Nanking
送出感谢: 0
接收感谢: 0
联系:

Re: [已解决]编译的时候出现这样的错误怎么办?

#4

帖子 choukuangjay » 2007-05-11 21:51

trarit 写了:
checking for MUSICAPPLET_DEPS... configure: error: Package requirements (
gtk+-2.0
libpanelapplet-2.0
pygtk-2.0
gnome-python-2.0
) were not met:

No package 'libpanelapplet-2.0' found
No package 'gnome-python-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MUSICAPPLET_DEPS_CFLAGS
and MUSICAPPLET_DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
貌似可以在环境变量里设置避免这个错误?
不大明鸟~
apt-get build-dep <package>,会自动安装好编译package所需要的一切的一切
ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营
回复

回到 “老旧版本支持”