安装xpdf以及xpdf-reader出现问题,remove也有问题了。

为当前最终发行版之前的所有版本提供支持
回复
头像
davidlone
帖子: 626
注册时间: 2007-03-06 18:14
来自: 常德--重庆
送出感谢: 0
接收感谢: 0
联系:

安装xpdf以及xpdf-reader出现问题,remove也有问题了。

#1

帖子 davidlone » 2007-05-11 13:19

最开始一次安装就有问题,后来安装就成这样了:

代码: 全选

davidlone@GGG:~$ sudo apt-get install xpdf xpdf-reader
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成      
xpdf-reader 已经是最新的版本了。
下列【新】软件包将被安装:
  xpdf
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 1320B/766kB 的软件包。
解压缩后会消耗掉 36.9kB 的额外空间。
获取:1 http://mirror.rootguide.org feisty/universe xpdf 3.01-9ubuntu3 [1320B]
下载 1320B,耗时 1s (850B/s)
选中了曾被取消选择的软件包 xpdf-reader。
(正在读取数据库 ... 系统当前总共安装有 106260 个文件和目录。)
正预备替换 xpdf-reader 3.01-9ubuntu3 (使用 .../xpdf-reader_3.01-9ubuntu3_i386.deb) ...
正在解压缩将用于更替的包文件 xpdf-reader ...
选中了曾被取消选择的软件包 xpdf。
正在解压缩 xpdf (从 .../xpdf_3.01-9ubuntu3_all.deb) ...
正在设置 xpdf-reader (3.01-9ubuntu3) ...

(update-desktop-database:8743): GLib-CRITICAL **: g_key_file_get_string_list: assertion `group_name != NULL' failed
Segmentation fault (core dumped)
dpkg:处理 xpdf-reader (--configure)时出错:
 子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 xpdf 的配置工作不能继续:
 xpdf 依赖于 xpdf-reader (= 3.01-9ubuntu3);然而:
  软件包 xpdf-reader 还没有被配置。
dpkg:处理 xpdf (--configure)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 xpdf-reader
 xpdf
E: Sub-process /usr/bin/dpkg returned an error code (1)
结果要卸载也出现问题,搞的每次装其他软件也会提示那个东东有错误,怎么解决:

代码: 全选

davidlone@GGG:~$ sudo apt-get remove xpdf xpdf-reader
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成      
下列软件包将被【卸载】:
  xpdf xpdf-reader
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 2097kB 的空间。
您希望继续执行吗?[Y/n]
(正在读取数据库 ... 系统当前总共安装有 106276 个文件和目录。)
正在删除 xpdf ...
正在删除 xpdf-reader ...

(update-desktop-database:8762): GLib-CRITICAL **: g_key_file_get_string_list: assertion `group_name != NULL' failed
Segmentation fault (core dumped)
dpkg:处理 xpdf-reader (--remove)时出错:
 子进程·post-removal script·返回了错误号·139
在处理时有错误发生:
 xpdf-reader
E: Sub-process /usr/bin/dpkg returned an error code (1)

在新立得里面也删除不了。修复安装也不行。

并且装其他软件的时候也会提示那个有问题,烦得很,怎么解决?
多谢!
回复

回到 “老旧版本支持”