7.04运行可执行程序出错

为当前最终发行版之前的所有版本提供支持
回复
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

7.04运行可执行程序出错

#1

帖子 zkxuchi » 2007-05-11 20:04

刚装的7.04 可是sudo ./xrgsu 运行此类的可执行程序时 一直提示sudo: unable to execute: No such file or directory 请问是什么原因啊 同样的程序在fc6下没问题啊
ls查看目录时 有绿色的xrgsu文件啊
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 anticlockwise » 2007-05-11 20:56

这样运行:

sudo sh ./xrgsu
头像
hao123liu
帖子: 887
注册时间: 2007-02-11 13:27
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 hao123liu » 2007-05-11 21:19

先 sudo chmod 777 xrgsu
然后运行
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zkxuchi » 2007-05-11 22:15

晕 用sudo sh ./xrgsu运行后提示:./xrgsu: 1: Syntax error: "(" unexpected
………………
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 anticlockwise » 2007-05-11 22:22

zkxuchi 写了:晕 用sudo sh ./xrgsu运行后提示:./xrgsu: 1: Syntax error: "(" unexpected
………………
……你从哪里下的这个?脚本都有误……
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 zkxuchi » 2007-05-11 23:09

官方的啊 以前fc6下用着很正常啊
thword
帖子: 119
注册时间: 2007-04-09 12:19
送出感谢: 0
接收感谢: 0

#7

帖子 thword » 2007-05-11 23:18

用sudo bash ./xrgsu

ubuntu默认的/bin/sh是链接到dash上的
dash跟bash还是有些不兼容
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 zkxuchi » 2007-05-11 23:35

……又出新问题了……
按ls的运行 提示:./xrgsu: cannot execute binary file
………… 彻底郁闷了
thword
帖子: 119
注册时间: 2007-04-09 12:19
送出感谢: 0
接收感谢: 0

#9

帖子 thword » 2007-05-11 23:44

是二进制文件? :shock:
如果是二进制文件,出错是正常的。(不同发行版下,很多二进制文件是不能通用的)

如果是脚本,那只有知道具体内容的情况下,才能判断哪里出问题了。
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 zkxuchi » 2007-05-11 23:53

别人的锐捷拨号都能用啊 晕 难道我点背…… 郁闷
thword
帖子: 119
注册时间: 2007-04-09 12:19
送出感谢: 0
接收感谢: 0

#11

帖子 thword » 2007-05-12 0:07

锐捷?这个论坛里就有不少人有同样的问题,有的已经解决了。
自己搜索一下吧。
freenb2003
帖子: 65
注册时间: 2006-10-27 23:59
送出感谢: 0
接收感谢: 0

#12

帖子 freenb2003 » 2007-05-12 0:10

你在重新下一个就是了啊,注意版本和你们学校的认证服务器版本一致就行了,我这里也用的这个,2.56版的,linux下的认证过程有点变态。
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#13

帖子 stlxv » 2007-05-12 5:34

用xsupplicant吧,不要用官方的
PHP是最好的语言!不服来战!
zkxuchi
帖子: 6
注册时间: 2007-01-11 0:14
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 zkxuchi » 2007-05-13 1:24

唉…… 用什么都不行 郁闷了 谢谢大家了 抽空装回FC6算了……
回复

回到 “老旧版本支持”