[问题]怎么让一个命令执行时不再需要输入密码?

为当前最终发行版之前的所有版本提供支持
回复
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

[问题]怎么让一个命令执行时不再需要输入密码?

#1

帖子 jaywee » 2007-05-13 8:01

每次开机我都需要运行

代码: 全选

sudo linux1x
这个命令来连接校园网,但麻烦的是每次都需要输入密码,我已经通过chmod命令赋于了h3c整个目录rwx权限,但还是需要输入密码。我想问一下有没有什么办法能运行这个命令时不再输入密码(不是sudo命令不再输入密码,只针对这个命令。)怎么实现??!!!
Time waits for no man!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 hualang0929 » 2007-05-13 9:05

其实 linux1x 本身不用root权限的,但是该程序调用了 libstdc
sudo很麻烦吗?要不你直接开机运行不是更方便。
抬头望星空一片晴,我独行,夜已渐寒……
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jaywee » 2007-05-13 9:19

我已经设置开机自动启动了,但总是掉,!!Faint!
Time waits for no man!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 hualang0929 » 2007-05-13 9:48

试试加在rc.local

代码: 全选

 cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

/etc/init.d/networking stop
ifconfig eth0 hw ether 00:30:18:b1:72:2d
/etc/init.d/networking start
ifconfig eth0 up

/usr/local/bin/linux1x

exit 0
抬头望星空一片晴,我独行,夜已渐寒……
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#5

帖子 drivel » 2007-05-13 11:15

因为连接网络需要root权限,所以即使你chmod了,也还是需要root密码才能执行!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 hualang0929 » 2007-05-13 11:21

drivel 写了:因为连接网络需要root权限,所以即使你chmod了,也还是需要root密码才能执行!
学习
抬头望星空一片晴,我独行,夜已渐寒……
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 jaywee » 2007-05-13 12:12

也就是说,只有将目前的帐户设置成root,除此别无他法了吗?
Time waits for no man!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 hualang0929 » 2007-05-13 15:07

都说了设成开机运行就不用那么麻烦。
4楼的方法可以解决,如果觉得不可靠自己写个脚本加到/etc/init.d/下
抬头望星空一片晴,我独行,夜已渐寒……
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 BigSnake.NET » 2007-05-13 15:12

setuid
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 jaywee » 2007-05-13 15:38

hualang0929 写了:都说了设成开机运行就不用那么麻烦。
4楼的方法可以解决,如果觉得不可靠自己写个脚本加到/etc/init.d/下
可能我话说得不清楚,我已经设置成开机自动启动了,但关键是有的时候总是掉,connection failed!这个时候我需要重新输入sudo linux1x来重新联接,你给出的脚本我试过了,还是需要输入密码!不知道是不是我的哪步操作有问题?是将代码直接copy进rc.local就行了吗?

另个,man楼上的setuid,似乎没有说明档,能给解释一下怎么用这个命令吗?
Time waits for no man!
回复

回到 “老旧版本支持”