[问题]保证基于QT的软件正常运行,应当安装哪些软件包?

为当前最终发行版之前的所有版本提供支持
回复
the7thevil
帖子: 61
注册时间: 2006-03-08 15:43
送出感谢: 0
接收感谢: 0

[问题]保证基于QT的软件正常运行,应当安装哪些软件包?

#1

帖子 the7thevil » 2007-05-13 22:25

我现在用的Ubuntu7.04,安装了很多基于QT的软件,如Kchmviewer、kigikam等等,但是在使用过程中遇到些问题,其一是在读写非主文件夹内的文件时经常出现11的错误而关闭,另一个问题是如GoogleEarth中无法正常显示弹出窗口。

因此,我想问应当安装那些软件包才能保证基于QT的全部软件都可以良好的运行?
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#2

帖子 stlxv » 2007-05-13 23:25

可能kdelibs吧
PHP是最好的语言!不服来战!
头像
iblicf
帖子: 3766
注册时间: 2007-01-15 17:15
送出感谢: 0
接收感谢: 0

#3

帖子 iblicf » 2007-05-14 0:57

咦 ? googleearth 基于QT么? 我还真不知道,,我的googleearth 挺正常,速度也很快,我是个破显卡,,
SIG11? 是非法内存访问,那是程序问题,会调试的用 gdb core 看看 。。。或者 lib问题,,你要不把qt3, qt4都装上
头像
ubuntusky
帖子: 185
注册时间: 2007-02-25 22:55
送出感谢: 0
接收感谢: 0

#4

帖子 ubuntusky » 2007-05-14 1:03

把kde的中文语言支持装上就行了(也可不装,只是字难看,konquorer之类的软件有可能是英文)

apt-get或新立德安装其它qt程序时,依赖的包会自动安装的,这个不必关心。
the7thevil
帖子: 61
注册时间: 2006-03-08 15:43
送出感谢: 0
接收感谢: 0

#5

帖子 the7thevil » 2007-05-14 17:02

谢谢楼上的解答

把KDE有关的包全装上算了,我就不相信还不行了,呵呵~~~~~
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

#6

帖子 tommy007 » 2007-05-14 17:47

。。。那还不如直接用kubuntu了。。。一般来说信号11是程序本身的缺陷
the7thevil
帖子: 61
注册时间: 2006-03-08 15:43
送出感谢: 0
接收感谢: 0

#7

帖子 the7thevil » 2007-05-14 19:52

呵呵,用惯了好多Gnome的软件,也懒得换过去了~~~~~

不过KDE下很多软件是相当好的~~~~~~
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 hualang0929 » 2007-05-14 20:48

QT != kde
抬头望星空一片晴,我独行,夜已渐寒……
回复

回到 “老旧版本支持”