安装软件的困惑[新手]

为当前最终发行版之前的所有版本提供支持
回复
mmjian
帖子: 4
注册时间: 2005-11-02 11:03
送出感谢: 0
接收感谢: 0

安装软件的困惑[新手]

#1

帖子 mmjian » 2005-11-02 11:18

Ubuntu似乎不能使用 ./configure;make;make install 来安装软件
它是不是只能用 apt-get 来安装他们服务器上指定的软件?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-11-02 11:22

安装编译环境就可以了。论坛有。
● 鸣学
mmjian
帖子: 4
注册时间: 2005-11-02 11:03
送出感谢: 0
接收感谢: 0

#3

帖子 mmjian » 2005-11-02 11:48

如...如何安装编译环境?

无意考验大侠的耐性,而是小弟刚接触Linux,找过很多文章来看,可还有很多东西都不得要领,看得也模糊,专业词语或缩写词太多
望多加耐心引领我等小辈入门

我输入 ./configure 命令时..,返回信息如下
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... no
checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See 'config.log' for more details.

我想我现在连正确描述Linux问题的能力都还没有,只好全敲下来了
例如 gawk;mawk;gcc;cc;cl 等等,虽知道缺这些东西,可如何得到并安装还是...还是一头雾水

如果大侠事务繁忙,给出一些有帮助的文章URL也行
万分感激..!!
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 catinsnow » 2005-11-02 11:57

代码: 全选

sudo apt-get install gcc g++ make
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#5

帖子 Tenyears » 2005-11-02 12:02

./configure;make;make install

这是设置、编译、安装

并不仅是安装软件

你需要编译环境来编译源代码

也就是需要C、C++之类的东西

再去读读资料吧

简单的处理就是,缺什么,你就用apt-get把它装上
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
ifu
帖子: 130
注册时间: 2005-10-25 15:08
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 ifu » 2005-11-02 13:49

sudo apt-get install build-essential

先安装基本的编译工具
http://www.ubuntu.org.cn/support/docume ... -essential
gxhunter
帖子: 63
注册时间: 2005-10-09 12:58
送出感谢: 0
接收感谢: 0

#7

帖子 gxhunter » 2005-11-02 22:29

和楼主同样的问题
GCC和G++等都装了
但输入./configure后
出现
bash: ./configure: 没有那个文件或目录
这怎么解决?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 karron » 2005-11-02 22:40

你要安装什么软件?你只有下载了源代码包之后,解压之后才能执行这个语句
xivhwo2002
帖子: 69
注册时间: 2005-10-23 17:43
来自: 地狱
送出感谢: 0
接收感谢: 0

#9

帖子 xivhwo2002 » 2005-11-02 22:41

./configure 是指运行当前目录下的configure 文件;
。就是指当前文件夹
上面的错误表示你没有进入那个编译的文件夹。
解决方法
1)cd /HOME/dir 指进入你那个要编译的软件的文件夹。
2)输入完整路径:如/home/dir/configure ,可以用tab键补齐路径呀,也很快
gxhunter
帖子: 63
注册时间: 2005-10-09 12:58
送出感谢: 0
接收感谢: 0

#10

帖子 gxhunter » 2005-11-02 22:52

原来如此,我编译的是SFC模拟器ZSNES,
那个目录里的确没有configure,怪不的一直编译不了


其他的问题我还是单独开贴问吧。
xivhwo2002
帖子: 69
注册时间: 2005-10-23 17:43
来自: 地狱
送出感谢: 0
接收感谢: 0

#11

帖子 xivhwo2002 » 2005-11-02 23:17

看看那个目录有没有 INSTALL or README 文件,打开看看或许对你有帮助。可以肯定是缺少了什么库文件或者一些依赖包……
AMD X2 3800+
DFI LanParty UT Ultra-D
DDR400 dual 1G * 2
2*sata 120G RAID 0
Ubuntu Dapper Drake 6.06 Prepare ing ……
gxhunter
帖子: 63
注册时间: 2005-10-09 12:58
送出感谢: 0
接收感谢: 0

#12

帖子 gxhunter » 2005-11-02 23:51

能帮忙看一下吗?谢谢了。
http://forum.ubuntu.org.cn/viewtopic.php?t=5448
回复

回到 “老旧版本支持”