7.04,源里面怎么没有acroread了?

为当前最终发行版之前的所有版本提供支持
回复
Ericzhao82
帖子: 275
注册时间: 2006-07-05 16:47
送出感谢: 0
接收感谢: 0

7.04,源里面怎么没有acroread了?

#1

帖子 Ericzhao82 » 2007-05-14 15:04

我用的是台湾的源,刚更新了。安装acroread时,发现没有这个软件了。

请教下,如果我想通过源来安装,那么该怎么安装呀?

谢谢
头像
fideas
帖子: 159
注册时间: 2007-04-29 17:26
送出感谢: 0
接收感谢: 0

#2

帖子 fideas » 2007-05-14 15:07

论坛上有人帖了地址了,你找一下吧,近期FTP登不上去,没得传
倩影暗香常入梦,莺声燕语犹在心.
Ericzhao82
帖子: 275
注册时间: 2006-07-05 16:47
送出感谢: 0
接收感谢: 0

#3

帖子 Ericzhao82 » 2007-05-14 15:15

http://forum.ubuntu.org.cn/viewtopic.ph ... ight=adobe

是上面这个吗?这个不行呀,在7.04上面,安装后,无法运行。

我在终端上面执行/usr/local/Adobe/Acrobat7.0/bin/acroread ,什么提示都没有,程序也没有能够运行。

奇怪,为何从源里面剔除掉呀
oylb
帖子: 41
注册时间: 2006-01-10 11:35
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 oylb » 2007-05-14 15:35

Ericzhao82 写了:http://forum.ubuntu.org.cn/viewtopic.php?t=37246&highlight=adobe

是上面这个吗?这个不行呀,在7.04上面,安装后,无法运行。

我在终端上面执行/usr/local/Adobe/Acrobat7.0/bin/acroread ,什么提示都没有,程序也没有能够运行。

奇怪,为何从源里面剔除掉呀

运行不了可能是scim和acroread的冲突
修改/usr/local/..../bin/acroread
在前面加入

LC_NUMERIC=C
export LC_NUMERIC
export GTK_IM_MODULE=xim
头像
fideas
帖子: 159
注册时间: 2007-04-29 17:26
送出感谢: 0
接收感谢: 0

#5

帖子 fideas » 2007-05-14 15:49

这个我试过是可以的,不过我说的不是这个,是有人发了deb包的源地址,还有skeype之类的no-free软件
倩影暗香常入梦,莺声燕语犹在心.
Ericzhao82
帖子: 275
注册时间: 2006-07-05 16:47
送出感谢: 0
接收感谢: 0

#6

帖子 Ericzhao82 » 2007-05-14 15:54

oylb 写了:
Ericzhao82 写了:http://forum.ubuntu.org.cn/viewtopic.php?t=37246&highlight=adobe

是上面这个吗?这个不行呀,在7.04上面,安装后,无法运行。

我在终端上面执行/usr/local/Adobe/Acrobat7.0/bin/acroread ,什么提示都没有,程序也没有能够运行。

奇怪,为何从源里面剔除掉呀

运行不了可能是scim和acroread的冲突
修改/usr/local/..../bin/acroread
在前面加入

LC_NUMERIC=C
export LC_NUMERIC
export GTK_IM_MODULE=xim


恩,好了,谢谢朋友。
yysirius
帖子: 63
注册时间: 2007-04-08 17:12
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yysirius » 2007-05-21 11:48

我安装以后 运行acroread 提示 "expr: 写入时发生错误" 一直刷屏
jolie
帖子: 42
注册时间: 2007-03-01 13:54
送出感谢: 0
接收感谢: 0

#8

帖子 jolie » 2007-05-21 12:43

楼上
打开acroread脚本,其中有这样一行:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)//g'

问题就出在这个“\([0-9]\)00”,显然它的意思就是000到900。可是我到我的/usr/lib目录下一看,我电脑中相应的库文件偏偏名叫 libgtk-x11-2.0.so.0.1000.6,中间的“1000”超出了它的查找范围。所以导致后面的一连串代码出错了。
解决方法很简单,对症下药,把这行代码改掉,改法有很多,只要能和自已的文件名匹配上就好,比如加一个星号:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00*.\([0-9]*\)\|\(.*\)//g'
这个狗狗上有的还是第一个的搜索结果的说
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 karron » 2007-05-21 13:02

再等等, ubuntu-cn里面我已经上传了acroread7.09的deb包, 等各个源同步好了估计就有了. 但是这个deb包里面估计没有中文字体, 如果是没有嵌入字体的中文pdf估计还是会乱码, 这个时候你adobe网站上下载一个中文字体包安装上估计就行了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
rucstudent
帖子: 633
注册时间: 2007-05-09 16:52
送出感谢: 1 次
接收感谢: 0

#10

帖子 rucstudent » 2007-05-21 13:22

oylb 写了:
Ericzhao82 写了:http://forum.ubuntu.org.cn/viewtopic.php?t=37246&highlight=adobe

是上面这个吗?这个不行呀,在7.04上面,安装后,无法运行。

我在终端上面执行/usr/local/Adobe/Acrobat7.0/bin/acroread ,什么提示都没有,程序也没有能够运行。

奇怪,为何从源里面剔除掉呀

运行不了可能是scim和acroread的冲突
修改/usr/local/..../bin/acroread
在前面加入

LC_NUMERIC=C
export LC_NUMERIC
export GTK_IM_MODULE=xim


我输入 gedit /usr/local/Adobe/Acrobat7.0/bin/acroread
怎么提示我说字符打不开?
yysirius
帖子: 63
注册时间: 2007-04-08 17:12
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 yysirius » 2007-05-21 13:30

jolie 写了:楼上
打开acroread脚本,其中有这样一行:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)//g'

问题就出在这个“\([0-9]\)00”,显然它的意思就是000到900。可是我到我的/usr/lib目录下一看,我电脑中相应的库文件偏偏名叫 libgtk-x11-2.0.so.0.1000.6,中间的“1000”超出了它的查找范围。所以导致后面的一连串代码出错了。
解决方法很简单,对症下药,把这行代码改掉,改法有很多,只要能和自已的文件名匹配上就好,比如加一个星号:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00*.\([0-9]*\)\|\(.*\)//g'
这个狗狗上有的还是第一个的搜索结果的说


果然可以了,谢谢你啦.
xiangyuyu
帖子: 39
注册时间: 2006-06-02 10:42
送出感谢: 0
接收感谢: 0

#12

帖子 xiangyuyu » 2007-07-28 20:55

jolie 写了:楼上
打开acroread脚本,其中有这样一行:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)//g'

问题就出在这个“\([0-9]\)00”,显然它的意思就是000到900。可是我到我的/usr/lib目录下一看,我电脑中相应的库文件偏偏名叫 libgtk-x11-2.0.so.0.1000.6,中间的“1000”超出了它的查找范围。所以导致后面的一连串代码出错了。
解决方法很简单,对症下药,把这行代码改掉,改法有很多,只要能和自已的文件名匹配上就好,比如加一个星号:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00*.\([0-9]*\)\|\(.*\)//g'
这个狗狗上有的还是第一个的搜索结果的说


谢谢!这个办法解决了我的问题,收藏!
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#13

帖子 qianwx » 2007-07-28 21:06

去官方下载安装吧,,,我附上无法启动的解决帮助。。。

代码: 全选

出错描述:安装完AdobeReader以后,无论直接双击PDF文件还是点击应用程序栏中的AdobeReader图标都无法启动,得不到任何响应。在终端中输入:/usr/bin/acroread以后出现错误提示:expr: 写入时发生错误

解决方法:

1 sudo nano /usr/bin/acroread

2  在文件最前面加入一行:GTK_IM_MODULE=xim

3  将文件中的“ echo $mfile| sed ’s/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g’” 替换为“ echo $mfile| sed ’s/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00*.\([0-9]*\)\|\(.*\)/\1\2\3/g’”

注意,不同版本的AdobeReader中此行的内容可能稍有不同,关键是在 [0-9]\)00后面增加一个*

感慨一下,这就是Linux不适合于普通用户的原因…

至于安装方法,下载的文件中有的。
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#14

帖子 内存不足 » 2007-07-28 21:42

真是麻烦 最怕装的就是这个东西
文件大个 装好了起不来 起来了不认中文
弄个中文包没安好老有提示需要中文字体................
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
回复

回到 “老旧版本支持”