常用的 apt 命令(ZT)

为当前最终发行版之前的所有版本提供支持
回复
bluepeng
帖子: 343
注册时间: 2007-04-02 14:35
送出感谢: 0
接收感谢: 0

常用的 apt 命令(ZT)

#1

帖子 bluepeng » 2007-05-16 10:00

常用的 apt 命令
apt-cache search package 搜索包
apt-cache show package 获取包的相关信息,如说明、大小、版本等
sudo apt-get install package 安装包
sudo apt-get install package - - reinstall 重新安装包
sudo apt-get -f install 修复安装"-f = --fix-missing"
sudo apt-get remove package 删除包
sudo apt-get remove package - - purge 删除包,包括删除配置文件等
sudo apt-get update 更新源
sudo apt-get upgrade 更新已安装的包
sudo apt-get dist-upgrade 升级系统
sudo apt-get dselect-upgrade 使用 dselect 升级
apt-cache depends package 了解使用依赖
apt-cache rdepends package 是查看该包被哪些包依赖
sudo apt-get build-dep package 安装相关的编译环境
apt-get source package 下载该包的源代码
sudo apt-get clean && sudo apt-get autoclean 清理无用的包
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#2

帖子 stlxv » 2007-05-16 11:04

:em32 :em33 ........无视
PHP是最好的语言!不服来战!
firefoxmmx
帖子: 407
注册时间: 2006-07-28 8:51
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 firefoxmmx » 2007-05-16 11:43

支持~~~
firefoxmmx
帖子: 407
注册时间: 2006-07-28 8:51
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 firefoxmmx » 2007-05-16 13:55

支持~~~
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#5

帖子 xiehuoli » 2007-05-16 13:58

我N年前就发过了
:em24
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#6

帖子 stlxv » 2007-05-16 15:11

xiehuoli 写了:我N年前就发过了
:em24
:em24:Jason Gunthorpe在2004年1月就把man手册页给写完了
PHP是最好的语言!不服来战!
头像
greco
帖子: 2487
注册时间: 2007-04-06 10:24
来自: ~/Shanghai
送出感谢: 0
接收感谢: 0

#7

帖子 greco » 2007-05-16 16:31

stlxv 写了:
xiehuoli 写了:我N年前就发过了
:em24
:em24:Jason Gunthorpe在2004年1月就把man手册页给写完了
初学者园地嘛....发发无所谓啊......
http://silenceisdefeat.com/~greco

代码: 全选

''.join([chr(ord(c)-2) for c in 'O{"G/ockn"ku<"itgeq0ujkBiockn0eqo'])
echo -n "Z3JlY28uc2hpQGdtYWlsLmNvbQ==" | base64 -d
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#8

帖子 xiehuoli » 2007-05-16 17:00

年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
zabbey
帖子: 296
注册时间: 2006-05-06 2:03
送出感谢: 0
接收感谢: 0

#9

帖子 zabbey » 2007-05-16 17:34

常用,所以都记在脑子里了的
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#10

帖子 stlxv » 2007-05-16 18:10

用新立得软件包管理器吧,命令行的aptitude也有集成界面可用,直接

代码: 全选

aptitude
就可以了
PHP是最好的语言!不服来战!
头像
守望桑田
帖子: 86
注册时间: 2007-04-19 7:33
来自: Xiamen
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 守望桑田 » 2007-05-17 13:21

常用熟练 常看自然记得牢

楼主也是为大家好啦 就不要这样说他了
人生的意义在于坚持不懈的折腾!
Weibo:http://weibo.com/Yousri
Blog:http://blog.yousri.org
Twitter:http://twitter.com/Yousri
chen8xu6tian6
帖子: 19
注册时间: 2006-07-10 18:55
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 chen8xu6tian6 » 2007-05-17 20:52

顶!!
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#13

帖子 stlxv » 2007-05-17 21:02

:shock:
PHP是最好的语言!不服来战!
michaeland2
帖子: 20
注册时间: 2006-12-24 1:21
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 michaeland2 » 2007-05-18 15:12

支持,刚用ubuntu,以后要多学习学习
回复

回到 “老旧版本支持”