安装配置过程中出现的错误 请高手解决一下 谢谢!

为当前最终发行版之前的所有版本提供支持
回复
caohuolong
帖子: 17
注册时间: 2007-05-06 14:05
送出感谢: 0
接收感谢: 0

安装配置过程中出现的错误 请高手解决一下 谢谢!

#1

帖子 caohuolong » 2007-05-16 18:17

checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

装软件的时候出现的错误 请问高手这个是什么意思?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-05-16 20:00

目录没权限?
● 鸣学
caohuolong
帖子: 17
注册时间: 2007-05-06 14:05
送出感谢: 0
接收感谢: 0

#3

帖子 caohuolong » 2007-05-16 21:44

hook@GhostShadow:~/save/gwget-0.98.2$ sudo ./configure -prefix=/home/hook/gwget
Password:
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gconftool-2... /usr/bin/gconftool-2
checking for intltool >= 0.29... 0.35.0 found
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for iconv... /usr/bin/iconv
checking for msgfmt... msgfmt
checking for msgmerge... msgmerge
checking for xgettext... xgettext
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.



我使用ROOT都不行?? 不知道是怎么的?
头像
fideas
帖子: 159
注册时间: 2007-04-29 17:26
送出感谢: 0
接收感谢: 0

#4

帖子 fideas » 2007-05-16 22:44

configure的时候不要用sudo,另外请确认你已经安装好必须的编译环境了
倩影暗香常入梦,莺声燕语犹在心.
头像
smallzhan
帖子: 112
注册时间: 2007-05-12 21:13
送出感谢: 0
接收感谢: 0

#5

帖子 smallzhan » 2007-05-16 23:01

.... 没有配置好编译环境

楼主请首先执行下面的命令:

代码: 全选

sudo apt-get install build-essential
然后再开始编译。另 gwget 是源里面有的软件,不用自己编译。直接搜索安装就是了。
回复

回到 “老旧版本支持”