请问哪里有GLib 2.0 development headers ?

为当前最终发行版之前的所有版本提供支持
回复
merlinc
帖子: 26
注册时间: 2006-09-27 0:55
送出感谢: 0
接收感谢: 0

请问哪里有GLib 2.0 development headers ?

#1

帖子 merlinc » 2007-05-16 22:59

ubuntu 7.04,因为是AMD64,要装pigdin2。0。0只好从源代码编译
下了源代码之后./configure输出:
checking for GLIB... no
no
configure: error:

You must have the GLib 2.0 development headers installed to build.

请问这个 Glib 2.0 开发环境头文件在哪里下载呢?为什么系统没有自带……
谢谢各位
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xport » 2007-05-16 23:11

代码: 全选

# sudo apt-get install "libglib2.0-dev"
PS:不要一帖多发~~~
其实我是一个演员!-http://blog.csdn.net/xport/
nomcoych
帖子: 179
注册时间: 2007-06-27 23:43
送出感谢: 0
接收感谢: 0

#3

帖子 nomcoych » 2007-07-09 21:12

加载libglib2.0deV新立得里面找。。。然后还有很多东西。。都加dev的就行,不过我还没有编译成功。。
nomcoych
帖子: 179
注册时间: 2007-06-27 23:43
送出感谢: 0
接收感谢: 0

#4

帖子 nomcoych » 2007-07-09 21:15

呵呵,已经解决,我忘记在MAKE前加SUDO了。
头像
tiancaiabc
帖子: 98
注册时间: 2007-01-11 0:40
送出感谢: 0
接收感谢: 0

#5

帖子 tiancaiabc » 2007-07-09 21:22

晕死了,sudo make install
green_cai
帖子: 42
注册时间: 2006-08-17 0:27
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 green_cai » 2007-09-06 23:13

多谢XPORT,我也碰到了这个问题
头像
alpeak
帖子: 94
注册时间: 2007-05-13 19:52
来自: Soochow, China
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 alpeak » 2007-10-02 10:37

我也有这个问题,但是按上面做了之后这个问题解决了。却又有了下面的问题。

You must have libxml2 >= 2.6.0 development headers installed to build.

但我的机子上已经装了LIBXML2了。而且也是不低于2.6.0的。不知道怎么办。
静下心,你能做到一切.

UBUNTU 8.04
AMD 速龙 3000+
DDR II 512*2
回复

回到 “老旧版本支持”