[问题]VMWare Workstation 5.5 C header files ?

为当前最终发行版之前的所有版本提供支持
回复
csust
帖子: 41
注册时间: 2006-12-29 12:16
送出感谢: 0
接收感谢: 0

[问题]VMWare Workstation 5.5 C header files ?

#1

帖子 csust » 2007-05-18 12:42

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]
?????可是我的有阿,那到底 C header files在那而呢?704版
sudo apt-get install linux-headers-2.6.20-15-generic
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
linux-headers-2.6.20-15-generic 已经是最新的版本了。
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xport » 2007-05-18 12:45

代码: 全选

sudo  apt-cache search "linux-headers-`uname -r`"
要安装与你目前kernel版本一致的headers !
其实我是一个演员!-http://blog.csdn.net/xport/
csust
帖子: 41
注册时间: 2006-12-29 12:16
送出感谢: 0
接收感谢: 0

#3

帖子 csust » 2007-05-18 12:52

xport 写了:

代码: 全选

sudo  apt-cache search "linux-headers-`uname -r`"
要安装与你目前kernel版本一致的headers !
uname -r
2.6.20-15-generic

是一致的把?
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 xport » 2007-05-18 12:58

代码: 全选

# cd /usr/src/linux-headers-`uname -r`/include
# pwd
其实我是一个演员!-http://blog.csdn.net/xport/
csust
帖子: 41
注册时间: 2006-12-29 12:16
送出感谢: 0
接收感谢: 0

#5

帖子 csust » 2007-05-18 13:14

xport 写了:

代码: 全选

# cd /usr/src/linux-headers-`uname -r`/include
# pwd
还是不行
The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match
your running kernel (version 2.6.20-15-generic). Even if the module were to
compile successfully, it would not load into the running kernel
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 xport » 2007-05-18 13:21

在安装 sudo /usr/bin/vmware-config.pl 这个么?

你VMWare什么版本呢?
其实我是一个演员!-http://blog.csdn.net/xport/
csust
帖子: 41
注册时间: 2006-12-29 12:16
送出感谢: 0
接收感谢: 0

#7

帖子 csust » 2007-05-18 13:39

xport 写了:在安装 sudo /usr/bin/vmware-config.pl 这个么?

你VMWare什么版本呢?
5.5的
我把他解压在我的HOME文件夹里,然后sudo ./vmware-install.p1
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 xport » 2007-05-18 13:44

或许是这个问题:

VMWare 5.5.x 在 Feisty 中有个兼容性的问题,你需要跳过安装时设定的那个步骤 !

手动修改vmnet, vmmon这2个模块中的源文件,然后再执行 sudo /usr/bin/vmware-config.pl 。

论坛里面有方法,你搜索看看!
其实我是一个演员!-http://blog.csdn.net/xport/
csust
帖子: 41
注册时间: 2006-12-29 12:16
送出感谢: 0
接收感谢: 0

#9

帖子 csust » 2007-05-18 13:49

xiexie
回复

回到 “老旧版本支持”