[问题]启动正常,进不了登录界面,报错信息如下:达人帮帮忙

为当前最终发行版之前的所有版本提供支持
回复
头像
skyforum
帖子: 54
注册时间: 2007-04-19 1:37
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

[问题]启动正常,进不了登录界面,报错信息如下:达人帮帮忙

#1

帖子 skyforum » 2007-05-18 13:15

用mplayer播放avi文件时由于加载的字幕是乱码,于是我想建立一个文字链接给mplayer,不小心出现了死机现象于是我就重启,重启到引导grub等都正常,也出现了ubuntu的登录进度画面,但是却始终无法出现登录的界面,鼠标一直处于忙状态,屏幕变黑,后来进入字符界面输入startx出现如下错误:
root@kebao:/etc #startx
xauth:creating new authority file /root/.serverauth.5036

X:warning:process set to priority -1 instead of requested priority 0

Fatal server error:
server is already active for displayer 0
if this serber is no longer running ,remove /tmp/.X0-lock
and start again

Xlib:connection to :0.0 refused
by server
Xlib:Invalid MIT-MAGIC-COOKIE
-1 key giving up
Xinit:unable to connect to X server
Xinit:No such process(error.3):server error


然后我按照提示删除了/tmp/.X0-lock但是仍然无法启动X,
达人请帮帮忙.
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#2

帖子 avauntage » 2007-05-18 15:37

代码: 全选

$ sudo dpkg-reconfigure xserver-xorg
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zmcbb30 » 2007-05-18 15:50

搞mplayer的字幕竟然有这种影响力 ?

什么操作?
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
头像
websnail
帖子: 270
注册时间: 2006-06-01 12:42
送出感谢: 0
接收感谢: 0

#4

帖子 websnail » 2007-05-18 23:29

首先删掉你建立的那个连接,然后删掉 /tmp/.X0-lock这个文件。再startx,如果还不行就照二楼的处理。
mplayer的字幕其实很简单,到首选项指定一个汉字字体,编码是Utf-8,字幕的编码再指定为GBK就没乱码了。
zwkuang
帖子: 252
注册时间: 2007-03-12 19:14
来自: 天各一方
送出感谢: 0
接收感谢: 0

#5

帖子 zwkuang » 2007-05-19 13:28

LZ强,居然链接字幕可以使得无法startx!
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 jaywee » 2007-05-19 14:00

:)
Time waits for no man!
回复

回到 “老旧版本支持”