使用apt-get总是出错

为当前最终发行版之前的所有版本提供支持
回复
sivaj
帖子: 541
注册时间: 2007-05-19 16:36
送出感谢: 0
接收感谢: 0

使用apt-get总是出错

#1

帖子 sivaj » 2007-05-19 16:44

使用sudo apt-get install安装软件时总是出现如下错误:
正在读取软件包列表... 完成
段错误析软件包的依赖关系树... 50%

请老手帮我解答一下问题出在哪儿,谢谢!
还有一个疑惑:
如果用which命令,查寻一个软件,如果的到结果,应该表示该软件已经安装了吧,比如用which java ,返回 /usr/bin/java 这样说明我的系统已经有了java环境 是这样吧?
头像
vbem
帖子: 239
注册时间: 2006-09-13 9:09
送出感谢: 0
接收感谢: 0

#2

帖子 vbem » 2007-05-19 16:49

代码: 全选

sudo apt-get update
sivaj
帖子: 541
注册时间: 2007-05-19 16:36
送出感谢: 0
接收感谢: 0

#3

帖子 sivaj » 2007-05-24 15:12

多谢楼上的
clarck8108
帖子: 25
注册时间: 2007-05-22 19:19
送出感谢: 0
接收感谢: 0

#4

帖子 clarck8108 » 2007-05-24 18:32

not followed
sivaj
帖子: 541
注册时间: 2007-05-19 16:36
送出感谢: 0
接收感谢: 0

#5

帖子 sivaj » 2007-06-02 15:24

玩了一段时间,算搞清楚了
出现错误 ,主要是源的问题,apt-get update一般在当时解决不了,如果急于用的话,将出现问题的源删掉,或者换源,然后update就好了当然换的源里面可能还会有问题,特别security那一行,如果果真出现这样的情况,删除那一行然后在update,直到不再出现问题,done为止。
回复

回到 “老旧版本支持”