[问题]求救。。急死小弟我了。。大家进来帮帮我。。

为当前最终发行版之前的所有版本提供支持
回复
头像
vacuumboby
帖子: 130
注册时间: 2005-06-13 21:19
来自: 湖南
送出感谢: 0
接收感谢: 0

[问题]求救。。急死小弟我了。。大家进来帮帮我。。

#1

帖子 vacuumboby » 2007-05-21 15:25

昨天晚上装了Ubuntu 5.10版。。后来通过
sudo apt-get update
sudo apt-get dist-upgrade 更新后提示更新至Ubuntu 7.04版我当时好高兴下了一通宵的包。又装了一白天。刚下班回来一看。重启后就提示 X Sever里面什么什么错误。后来自动弹出选项好像是要配置显卡。但是里面又没有选项 真是不知道怎么办了。请大家帮帮我。。谢谢。。。我现在都是用的Knoppix上的网。。急哟。。谢谢了。
上次由 vacuumboby 在 2007-05-21 15:33,总共编辑 1 次。
头像
vacuumboby
帖子: 130
注册时间: 2005-06-13 21:19
来自: 湖南
送出感谢: 0
接收感谢: 0

#2

帖子 vacuumboby » 2007-05-21 15:29

对了。。刚想起来我回来的时候又加了个-f参数再进行了一次升级。不知道会不会有影响。。如果是显卡参数不对请大哥们指教如何修改。谢谢。。
头像
vacuumboby
帖子: 130
注册时间: 2005-06-13 21:19
来自: 湖南
送出感谢: 0
接收感谢: 0

#3

帖子 vacuumboby » 2007-05-21 15:47

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV5 [RIVA TNT2/TNT2 Pro]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "1770DF"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV5 [RIVA TNT2/TNT2 Pro]"
Monitor "1770DF"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection


以上为小弟我的xorg.conf 是不是哪里需要修改。。如何修改请指教。。谢谢。。
头像
vacuumboby
帖子: 130
注册时间: 2005-06-13 21:19
来自: 湖南
送出感谢: 0
接收感谢: 0

#4

帖子 vacuumboby » 2007-05-22 17:20

不明白。。。这个大个论坛。却没有人能帮助我。。。汗颜啊。。
lxi
帖子: 8
注册时间: 2007-01-05 11:13
送出感谢: 0
接收感谢: 0

#5

帖子 lxi » 2007-05-22 17:25

错误不贴出来就只有祈求上帝帮帮你罗
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#6

帖子 jimmin » 2007-05-22 17:36

安装好显卡驱动没?装好了就运行下面的试试(运行前先备份/etc/X11/xorg.conf)。

代码: 全选

sudo nvidia-glx-config enable
sudo nvidia-xconfig
头像
vacuumboby
帖子: 130
注册时间: 2005-06-13 21:19
来自: 湖南
送出感谢: 0
接收感谢: 0

#7

帖子 vacuumboby » 2007-05-22 18:27

楼上的方法我去试试。。回头再来说说情况。。我的错误信息。。


Failed to start the X server (your graphical interface). It is lidely that it is not setup carrectly. Would you like to view the X Server output to diagnose the problem?


不知道是不是哪里的设置有误。去试试重新配置一下。谢谢楼上的。
回复

回到 “老旧版本支持”