当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]求救。。急死小弟我了。。大家进来帮帮我。。
帖子发表于 : 2007-05-21 15:25 
头像

注册: 2005-06-13 21:19
帖子: 130
地址: 湖南
送出感谢: 0 次
接收感谢: 0 次
昨天晚上装了Ubuntu 5.10版。。后来通过
sudo apt-get update
sudo apt-get dist-upgrade 更新后提示更新至Ubuntu 7.04版我当时好高兴下了一通宵的包。又装了一白天。刚下班回来一看。重启后就提示 X Sever里面什么什么错误。后来自动弹出选项好像是要配置显卡。但是里面又没有选项 真是不知道怎么办了。请大家帮帮我。。谢谢。。。我现在都是用的Knoppix上的网。。急哟。。谢谢了。


最后由 vacuumboby 编辑于 2007-05-21 15:33,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-21 15:29 
头像

注册: 2005-06-13 21:19
帖子: 130
地址: 湖南
送出感谢: 0 次
接收感谢: 0 次
对了。。刚想起来我回来的时候又加了个-f参数再进行了一次升级。不知道会不会有影响。。如果是显卡参数不对请大哥们指教如何修改。谢谢。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-21 15:47 
头像

注册: 2005-06-13 21:19
帖子: 130
地址: 湖南
送出感谢: 0 次
接收感谢: 0 次
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV5 [RIVA TNT2/TNT2 Pro]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "1770DF"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV5 [RIVA TNT2/TNT2 Pro]"
Monitor "1770DF"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection


以上为小弟我的xorg.conf 是不是哪里需要修改。。如何修改请指教。。谢谢。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-22 17:20 
头像

注册: 2005-06-13 21:19
帖子: 130
地址: 湖南
送出感谢: 0 次
接收感谢: 0 次
不明白。。。这个大个论坛。却没有人能帮助我。。。汗颜啊。。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-22 17:25 

注册: 2007-01-05 11:13
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
错误不贴出来就只有祈求上帝帮帮你罗


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-22 17:36 

注册: 2006-09-24 4:37
帖子: 2138
送出感谢: 0 次
接收感谢: 1
安装好显卡驱动没?装好了就运行下面的试试(运行前先备份/etc/X11/xorg.conf)。
代码:
sudo nvidia-glx-config enable
sudo nvidia-xconfig


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-22 18:27 
头像

注册: 2005-06-13 21:19
帖子: 130
地址: 湖南
送出感谢: 0 次
接收感谢: 0 次
楼上的方法我去试试。。回头再来说说情况。。我的错误信息。。


Failed to start the X server (your graphical interface). It is lidely that it is not setup carrectly. Would you like to view the X Server output to diagnose the problem?


不知道是不是哪里的设置有误。去试试重新配置一下。谢谢楼上的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Alexa [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译