apt 怎样设置代理(解决了)

为当前最终发行版之前的所有版本提供支持
回复
yellowman
帖子: 34
注册时间: 2005-10-21 12:16
送出感谢: 0
接收感谢: 0
联系:

apt 怎样设置代理(解决了)

#1

帖子 yellowman » 2005-11-05 9:57

我用的是ubuntu 5.10 通过设置浏览器代理 可以正常浏览网页,但是无法使用apt-get 来更新,不知道是为什么?是不是在哪设置apt 的代理呢?怎么样设置呢?
上次由 yellowman 在 2005-11-17 14:14,总共编辑 1 次。
james4e
帖子: 53
注册时间: 2005-06-08 20:18
送出感谢: 0
接收感谢: 0

#2

帖子 james4e » 2005-11-05 11:25

系统->首选项->网络代理

设置全局全局代理。
jieying
帖子: 371
注册时间: 2005-11-03 17:52
送出感谢: 0
接收感谢: 0

#3

帖子 jieying » 2005-11-05 12:15

System>Preferences>Network Proxy,
Automatic proxy configuration
http://proxy2.*.edu.cn:8080/proxy.pac
It didn't work.
feex
帖子: 85
注册时间: 2005-09-29 1:16
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 feex » 2005-11-05 12:35

终端下键入 export http_proxy=http://xxx.xxx.xxx.xxx:xxxx
zhuzhzh
帖子: 265
注册时间: 2005-07-28 15:08
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zhuzhzh » 2005-11-05 16:42

引言
引用:

很多地方由于处于内网,不能直接访问外网,需要通过代理,并输入验证信息才能上网。由些产生了一系统的不便。本篇文章简单介绍一下作者的解决方案



浏览网页
引用:

对于firefox直接在“首选项”里输入代理,上网时会跳出验证对话框
我试过写脚本,不过脚本好像不支持验证



APT更新
引用:

在/etc/apt下创建一文件apt.conf
在里面输入
Acquire::http::Proxy "http://usrer:password@proxyip:port";
这样就可以进行apt更新了
无声胜有声
jieying
帖子: 371
注册时间: 2005-11-03 17:52
送出感谢: 0
接收感谢: 0

#6

帖子 jieying » 2005-11-07 5:55

按照楼上的方法,我设置成功了,非常感谢!希望楼主尽快搞掂,早日享受Ubuntu带给我们的快乐
leoyang
帖子: 3
注册时间: 2005-11-13 12:21
送出感谢: 0
接收感谢: 0

#7

帖子 leoyang » 2005-11-13 23:25

zhuzhzh 写了:引言
引用

在/etc/apt下创建一文件apt.conf
在里面输入
Acquire::http::Proxy "http://usrer:password@proxyip:port";
这样就可以进行apt更新了


what about ftp? I wrote something like :

Acquire::ftp::Proxy "ftp://user:pass@ip:1080"; (socks proxy)
or:
Acquire::ftp::Proxy "http://user:pass@ip:8080"; (http proxy)

But neither works!What can I do now?
victorhu
帖子: 7
注册时间: 2005-11-24 23:36
送出感谢: 0
接收感谢: 0

#8

帖子 victorhu » 2005-11-25 10:16

是啊,我也有7楼的问题。按5楼的方法确实可行,但不知7楼的说法为什么不行呢?原理是什么?
回复

回到 “老旧版本支持”