[问题]./configure时碰到erorr : Cannot find glib2/gtk2/pango问题

为当前最终发行版之前的所有版本提供支持
回复
jordanh
帖子: 7
注册时间: 2007-05-17 11:30
送出感谢: 0
接收感谢: 0
联系:

[问题]./configure时碰到erorr : Cannot find glib2/gtk2/pango问题

#1

帖子 jordanh » 2007-05-22 23:09

我是vmware安装的6.10,在audacious的主页下了audacious1.3.2版本的tgz包,在./configure时出现
checking for glib-2.0 >= 2.60 gtk+2.0>= 2.60 thread-2.0 pango ...no
configure: erorr : Cannot find glib2/gtk2/pango
但相关的glib包我都有安装啊.请问这个问题怎么解决啊.
另.我在新立得里面找不到audacious.是不是没有添加audacious的源啊.....
rayman
帖子: 123
注册时间: 2006-10-28 19:31
来自: 中国,广西,南宁
送出感谢: 0
接收感谢: 0

#2

帖子 rayman » 2007-05-23 0:34

应该是glib2/gtk2版本过低
我在7.04上装1.3.2的版本也遇到过这种情况


7.04的源里有audacious的,版本是1.2.2
jordanh
帖子: 7
注册时间: 2007-05-17 11:30
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jordanh » 2007-05-23 0:43

先谢谢rayman的回复了.
那如此说来的话就是我在6.10上用的audacious的版本太高??那我先去找一个低版本的去试试看~~tks~
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

#4

帖子 tommy007 » 2007-05-23 6:25

。。。。。。。。。glib2/gtk2/pango 的dev包没装
6.06都可以用最新的audacious
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 xport » 2007-05-23 8:11

记得多去看看FAQ,这个是缺少Pango Library...

代码: 全选

# sudo apt-get install "libpango1.0-dev"
其实我是一个演员!-http://blog.csdn.net/xport/
jordanh
帖子: 7
注册时间: 2007-05-17 11:30
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 jordanh » 2007-05-23 18:59

根据xport提供的信息.我在
http://packages.ubuntu.com/cgi-bin/sear ... ngo1.0-dev
下载并安装了libpango1.0的deb包(其实我的系统已经安装了该包....).
问题依然继续...[/url]
头像
maple_
帖子: 271
注册时间: 2011-03-24 8:05
送出感谢: 0
接收感谢: 1 次

Re: [问题]./configure时碰到erorr : Cannot find glib2/gtk2/pango问题

#7

帖子 maple_ » 2011-04-30 15:34

安装了libglib2.0-dev后。。。这个错误小时了。。。
然后又缺少gtk+2 :em25
真是崩溃。。。
头像
maple_
帖子: 271
注册时间: 2011-03-24 8:05
送出感谢: 0
接收感谢: 1 次

Re: [问题]./configure时碰到erorr : Cannot find glib2/gtk2/pango问题

#8

帖子 maple_ » 2011-04-30 15:36

又安装了libgtk2.0-dev。。。上面的问题又解决了。。。
接着
configure: error:
libmowgli version 0.7.1 was found, but libmowgli >= 0.9 is required.
我想撞墙了。。。 :em20
头像
maple_
帖子: 271
注册时间: 2011-03-24 8:05
送出感谢: 0
接收感谢: 1 次

Re: [问题]./configure时碰到erorr : Cannot find glib2/gtk2/pango问题

#9

帖子 maple_ » 2011-04-30 15:39

这个怎么办啊。。。libmowgli 0.9...
回复

回到 “老旧版本支持”