请问:ubuntu里有有自带的samba吗,要不要自已安装啊

为当前最终发行版之前的所有版本提供支持
回复
高级铲铲员
帖子: 1
注册时间: 2007-05-27 7:50
送出感谢: 0
接收感谢: 0

请问:ubuntu里有有自带的samba吗,要不要自已安装啊

#1

帖子 高级铲铲员 » 2007-05-27 7:52

因为我发现用service smb start这个命令没有啊
omgkent
帖子: 31
注册时间: 2007-05-21 22:03
送出感谢: 0
接收感谢: 0

#2

帖子 omgkent » 2007-05-29 21:50

在x下》系统选项(或另一个)》共享文件,会自动安装
配置我好像不成功~哎
luoswebid
帖子: 3
注册时间: 2006-10-27 19:01
送出感谢: 0
接收感谢: 0

网上搜到的

#3

帖子 luoswebid » 2007-05-30 0:52

首先当然是要安装samba了,呵呵:
代码:
sudo apt-get install samba
sudo apt-get install smbfs


下面我们来共享群组可读写文件夹,假设你要共享的文件夹为: /home/ray/share

首先创建这个文件夹
代码:
mkdir /home/ray/share
chmod 777 /home/ray/share


备份并编辑smb.conf允许网络用户访问
代码:
sudo cp /etc/samba/smb.conf /etc/samba/smb.conf_backup
sudo gedit /etc/samba/smb.conf


搜寻这一行文字
代码:
; security = user


用下面这几行取代
代码:
security = user
username map = /etc/samba/smbusers


将下列几行新增到文件的最后面,假设允许访问的用户为:newsfan。而文件夹的共享名为 Share

代码:
[Share]
comment = Shared Folder with username and password
path = /home/ray/share
public = yes
writable = yes
valid users = newsfan
create mask = 0700
directory mask = 0700
force user = nobody
force group = nogroup
available = yes
browseable = yes


然后顺便把这里改一下,找到[global]把 workgroup = MSHOME 改成
代码:
workgroup = WORKGROUP
display charset = UTF-8
unix charset = UTF-8
dos charset = cp936

后面的三行是为了防止出现中文目录乱码的情况。其中根据你的local,UTF-8 有可能需要改成 cp936。自己看着办吧。

现在要添加newsfan这个网络访问帐户。如果系统中当前没有这个帐户,那么
代码:
sudo useradd newsfan

要注意,上面只是增加了newsfan这个用户,却没有给用户赋予本机登录密码。所以这个用户将只能从远程访问,不能从本机登录。而且samba的登录密码可以和本机登录密码不一样。

现在要新增网络使用者的帐号:
代码:
sudo smbpasswd -a newsfan
sudo gedit /etc/samba/smbusers


在新建立的文件内加入下面这一行并保存
代码:
newsfan = "network username"


如果将来需要更改newsfan的网络访问密码,也用这个命令更改
代码:
sudo smbpasswd -a newsfan


删除网络使用者的帐号的命令把上面的 -a 改成 -x
代码:
sudo testparm
sudo /etc/init.d/samba restart

最后退出重新登录或者重新启动一下机器。
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

Re: 请问:ubuntu里有有自带的samba吗,要不要自已安装啊

#4

帖子 stlxv » 2007-05-30 12:31

高级铲铲员 写了:因为我发现用service smb start这个命令没有啊
这个命令和samba关系不大,这是redhat的服务管理体系,和ubuntu是不一样的

默认ubuntu至少安装了samba client。
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”