编译gspcav(摄像头驱动)的问题,linux-headers的问题[已解决]

为当前最终发行版之前的所有版本提供支持
回复
shada
帖子: 397
注册时间: 2006-09-27 11:17
送出感谢: 1 次
接收感谢: 3 次
联系:

编译gspcav(摄像头驱动)的问题,linux-headers的问题[已解决]

#1

帖子 shada » 2007-05-29 22:15

/usr/src/gspcav1-20070508/gspca_core.c:2303: 错误: ‘VIDIOCSYNC’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2354: 错误: ‘VIDIOCGFBUF’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2357: 错误: ‘sizeof’ 不能用于不完全的类型 ‘struct video_buffer’
/usr/src/gspcav1-20070508/gspca_core.c:2358: 错误: 提领指向不完全类型的指针
/usr/src/gspcav1-20070508/gspca_core.c:2361: 错误: ‘BASE_VIDIOCPRIVATE’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2393: 错误: ‘VIDIOCKEY’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2395: 错误: ‘VIDIOCCAPTURE’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2397: 错误: ‘VIDIOCSFBUF’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2399: 错误: ‘VIDIOCGTUNER’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2400: 错误: ‘VIDIOCSTUNER’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2402: 错误: ‘VIDIOCGFREQ’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2403: 错误: ‘VIDIOCSFREQ’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2405: 错误: ‘VIDIOCGAUDIO’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c:2406: 错误: ‘VIDIOCSAUDIO’ 未声明 (在此函数内第一次使用)
/usr/src/gspcav1-20070508/gspca_core.c: 在函数 ‘cd_to_spca50x’ 中:
/usr/src/gspcav1-20070508/gspca_core.c:2616: 警告: 隐式声明函数 ‘to_video_device’
/usr/src/gspcav1-20070508/gspca_core.c:2616: 警告: 初始化时将整数赋给指针,未作类型转换
/usr/src/gspcav1-20070508/gspca_core.c: 在函数 ‘spca50x_create_sysfs’ 中:
/usr/src/gspcav1-20070508/gspca_core.c:2655: 警告: 隐式声明函数 ‘video_device_create_file’
/usr/src/gspcav1-20070508/gspca_core.c:2665: 警告: 隐式声明函数 ‘video_device_remove_file’
make[2]: *** [/usr/src/gspcav1-20070508/gspca_core.o] 错误 1
make[1]: *** [_module_/usr/src/gspcav1-20070508] 错误 2
make[1]: Leaving directory `/usr/src/linux-2.6.21.2'
make: *** [default] 错误 2
root@laf163-desktop:/usr/src/gspcav1-20070508#

以上是编译时的错误代码,发行版:ubuntu7.04,内核是我自己编译的2.6.21.2,
uname -r是2.6.21.2linuxdiy
可是apt-get不到linux-headers-2.6.21.2linuxdiy(能get到才怪),然后我自己
copy了一个/usr/src/linux-2.6.21.2为/usr/src/linux-headers-2.6.21.2linuxdiy
仍然是上面的错误,请问如何解决。


已解决,原来是因为内核没有支持usb视频捕捉,重新编译后就可以了,并不是linux-headers的问题。
dolin
帖子: 14
注册时间: 2008-12-28 19:54
送出感谢: 0
接收感谢: 0

Re: 编译gspcav(摄像头驱动)的问题,linux-headers的问题[已解决]

#2

帖子 dolin » 2009-02-09 16:25

内核:linux2.6.27.11
到这儿下载两个文件
http://www.slackware.com/~alien/slackbu ... av1/build/

gspca_kernel_2.6.27.diff
gspcav1-20071224.tar.gz
第一个文件是补丁文件,LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)用就用得上了。
第二个是驱动文件。

解压:
gspcav1-20071224.tar.gz并进入其目录,拷贝
gspca_kernel_2.6.27.diff到此目录。

当前目录运行命令:
patch -p1<gspca_kernel_2.6.27.diff
进行补丁
然后:
make clean
make
sudo make install
然后
sudo gedit /etc/modprobe.d/options
加入
options gspca force_rgb=1
即可

cheese运行正常
我的camorama还不能找到驱动
回复

回到 “老旧版本支持”