安装ubuntu 5.10出错。

为当前最终发行版之前的所有版本提供支持
回复
zard
帖子: 8
注册时间: 2005-11-08 22:16
送出感谢: 0
接收感谢: 0

安装ubuntu 5.10出错。

#1

帖子 zard » 2005-11-08 22:18

输入loadlin vmlinuz root=/dev/ram initrd=initrd.gz ramdisk_size=20000 devfs=mount.dall

后出错:
Uncompressing linux...
invalid compressed format(err=2)
system halted

然后死机
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 dongmh » 2005-11-08 22:19

应该输入
vmlinuz /vmlinuz root=/dev/ram ramdisk_size=20000 devfs=mount,dall
initrd /initrd.gz
ubuntu 6.06
我是初学者 大家多多关照
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 dongmh » 2005-11-08 22:20

我是这么想的不一定对
试一下吧
ubuntu 6.06
我是初学者 大家多多关照
zard
帖子: 8
注册时间: 2005-11-08 22:16
送出感谢: 0
接收感谢: 0

#4

帖子 zard » 2005-11-08 22:24

刚试过了,无此命令...
ygleung
帖子: 186
注册时间: 2005-10-17 20:53
送出感谢: 0
接收感谢: 0

#5

帖子 ygleung » 2005-11-08 23:13

指令看来没问题,是不是下载了错误的vmlinuz和initrd.gz?? net-install? hdmedia install?
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

Re: 安装ubuntu 5.10出错。

#6

帖子 catinsnow » 2005-11-09 0:54

zard 写了:输入loadlin vmlinuz root=/dev/ram initrd=initrd.gz ramdisk_size=20000 devfs=mount.dall

把initrd.gz解压出来,用解压出来的文件名替换掉initrd.gz试试.最后是mount,dall
是逗号.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#7

帖子 catinsnow » 2005-11-09 0:57

dongmh 写了:应该输入
vmlinuz /vmlinuz root=/dev/ram ramdisk_size=20000 devfs=mount,dall
initrd /initrd.gz

是用grub for dos安装时所用的,楼主用的loadin.并且vmlinuz要换成kernel.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
zard
帖子: 8
注册时间: 2005-11-08 22:16
送出感谢: 0
接收感谢: 0

#8

帖子 zard » 2005-11-10 11:45

已经安装成功了。用loadlin命令安装的。

出错的原因是vmlinuz和initrd.gz两个文件不完整。

不知什么原因,用flashget和直接下载的文件大小不一样。

前两次是直接下载的(目标另存为),安装出错。

最后用flashget拖下来的,比较顺利就安装成功了。

安装过程中,我选择了下载语言支持,结果进不去xwindow,

重新安装,不下载语言支持,顺利进入xwindow。

为什么?
回复

回到 “老旧版本支持”