当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]升级遇到错误
帖子发表于 : 2007-05-31 7:53 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

升级系统文件和信里的都遇到这样的错误。。
如何修正。。谢谢大家 ~~
本人新手第一次接触UBUNTU。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:05 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
可能上次安装某个软件没有装好。

首先确认你的源设置的是正确的。

然后尝试修复依赖关系。
代码:
sudo apt-get install -f


然后重新配置软件包。
代码:
sduo dpkg --configure -a


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:20 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
你给出的 代码 是不是在应用程序 附件 终端 这里输入的。。
我看了些置顶的帖子一些新手介绍。还是没看懂,总觉得卡在设么地方了。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:24 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
代码一般都是要在终端中运行的。
置顶的帖子里面有很多都是过时了的,你可以参考一下Feisty快速设置指南


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:25 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
从以下各服务器列表内容中选择一段替换文件中的所有内容,为防止非官方源中软件包不全的问题,请在sources.list文件中尾部添加一组官方源。

我 把sources.list文件改成以下设置是否这正确
deb http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:38 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
kikacheng@kikacheng-desktop:~$ sudo apt-get install -f
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
kikacheng@kikacheng-desktop:~$ sduo dpkg --configure -a
bash: sduo:找不到命令
kikacheng@kikacheng-desktop:~$

不行阿 。。。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:42 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
sudo


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:44 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
avauntage 写道:
sudo

kikacheng@kikacheng-desktop:~$ sudo dpkg --configure -a
正在设置 capplets-data (2.18.1-0ubuntu2.1) ...

dpkg:依赖关系问题使得 gnome-panel 的配置工作不能继续:
gnome-panel 依赖于 gnome-panel-data (= 1:2.18.1-0ubuntu3.1);然而:
系统中 gnome-panel-data 的版本为 1:2.18.1-0ubuntu3。
dpkg:处理 gnome-panel (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 libpanel-applet2-0 (2.18.1-0ubuntu3.1) ...

正在设置 python2.5 (2.5.1-0ubuntu1) ...

正在设置 metacity-common (2.18.2-0ubuntu1.1) ...

正在设置 app-install-data-commercial (7.1) ...
Caching application data...
Got non-package menu entry grdesktop.desktop
Got non-package menu entry tsclient.desktop
Got non-package menu entry brasero.desktop
Got non-package menu entry k3dsurf.desktop
Got non-package menu entry kmyfirewall.desktop
Got non-package menu entry kiso.desktop
Got non-package menu entry xchm.desktop
Generating mime/codec maps...

正在设置 libmetacity0 (2.18.2-0ubuntu1.1) ...

正在设置 libslab0 (2.18.1-0ubuntu2.1) ...

dpkg:处理 gnome-panel-data (--configure)时出错:
该软件包正处于非常不稳定的状态 - 您最好
在配置它之前,先重新安装它。
正在设置 python (2.5.1-0ubuntu3) ...

正在设置 libgnome-window-settings1 (2.18.1-0ubuntu2.1) ...

正在设置 update-manager-core (0.59.20) ...

正在设置 gnome-control-center (2.18.1-0ubuntu2.1) ...

正在设置 python-problem-report (0.76.1) ...

正在设置 python-apport (0.76.1) ...

正在设置 apport (0.76.1) ...
* Starting automatic crash report generation: apport [ OK ]

正在设置 apport-gtk (0.76.1) ...
在处理时有错误发生:
gnome-panel
gnome-panel-data
kikacheng@kikacheng-desktop:~$


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:51 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
可以了,。。谢谢你了。。。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:51 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get remove --purge  gnome-panel gnome-panel-data

然后再
代码:
sudo apt-get update

如果没有错误再
代码:
sudo apt-get install gnome-panel gnome-panel-data


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-31 8:57 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我是nvidia的显卡想安装BERYL需要作到哪里步骤


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-05-31 9:24 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
1、sudo apt-get install nvidia-glx (nvidia系列显卡的装这个,显卡型号可以用lspci查看)
2、sudo apt-get install beryl emerald-themes
3、sudo apt-get install beryl-manager
4、Ctrl+Alt+Backspace重启X。这个Backspace是键盘右上方的那个,不是方向键的左箭头。
5、打开一个命令终端。运行beryl-manager。

想开机自动运行?
系统-首选项-会话-启动程序-新建,名称:beryl,命令:/usr/bin/beryl-manager


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-05-31 9:42 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
前面3部都可以就是Ctrl+Alt+Backspace重启X
之后是注销。。然后进入系统之后提示两个文件错误。叫我删除。

好像可以了。。。谢谢你了 。。在屏幕的右上方出现了个红色的砖石


最后由 kika 编辑于 2007-05-31 9:49,总共编辑了 1 次

页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-05-31 9:49 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
see...


附件:
keyboard.gif
keyboard.gif [ 45.29 KiB | 被浏览 508 次 ]



_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-05-31 9:50 

注册: 2007-05-27 2:35
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
实在是太感谢你了。avauntage
:D :D


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译